Skip to main content
← Vulnerabilities

Command Injection in IPsec VPN

Welotec TK-series devices with the IPsec VPN function in use are affected on firmware before 3.5.116 (TK100), 1.0.124 (TK500-v2) or 1.0.123 (TK500-v3). Fixed in those releases.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.6HighCNA
Exploited
No known exploitation
Fix
Fixed in 3.5.116, 1.0.124, 1.0.123
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. The IPsec VPN function of the device is in use. Device runs an affected Welotec TK-series firmware version below the fixed release for its model (for example TK102L/TK102W/TK100 below 3.5.116).

18Pcve.now Index 18 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity9.6/10CVSS 8.6, total technical impact per CISA
  • No patch0/5No signal

What would change the score

  • Would score about 68 if added to CISA KEV
  • Would score about 63 if CISA's SSVC rates exploitation active
  • Would score about 25 if CISA's SSVC rates it automatable

CVE-2026-105982 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects TK100, TK500-v2 and TK500-v3; fixed in 3.5.116, 1.0.124 and 1.0.123.

Published
Last modified
Published
Not listed in CISA KEV
0.47% · 40th percentile
18/100 · provisional
Specific setups only
Fix
Fixed in 3.5.116, 1.0.124, 1.0.123
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

This vulnerability affects the IPsec VPN function of the affected product, which is a network security feature that encrypts traffic between sites or devices. A remote attacker who already has high-level privileges could exploit improper input validation to run arbitrary system commands with root-level access.

Read the original description

Improper input validation in the IPsec VPN function may allow a remote attacker with high privileges to inject system commands and execute them with root privileges.

What to do

  • Check whether your setup matches what the bug needs.

    The IPsec VPN function of the device is in use. Device runs an affected Welotec TK-series firmware version below the fixed release for its model (for example TK102L/TK102W/TK100 below 3.5.116).
  • Upgrade to a fixed version: 3.5.116, 1.0.124, 1.0.123.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  4. Record last updated

Affected versions

  • Welotec TK100

    From 0.0.0 · fixed in 3.5.116

  • Welotec TK500-v2

    From 0.0.0 · fixed in 1.0.124

  • Welotec TK500-v3

    From 0.0.0 · fixed in 1.0.123

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-105982

Is CVE-2026-105982 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Improper input validation in the IPsec VPN function allows command injection, meaning injected system commands can run with root privileges. The impact is high for confidentiality, integrity and availability.Source: certvde.com

Which versions are affected by CVE-2026-105982?

TK100: from 0.0.0 before 3.5.116. TK500-v2: from 0.0.0 before 1.0.124. TK500-v3: from 0.0.0 before 1.0.123.Source: cve.now feed data

Am I affected, and how do I check?

Firmware below 3.5.116 on TK100, below 1.0.124 on TK500-v2, and below 1.0.123 on TK500-v3 is affected, but only where the IPsec VPN function is in use. To check, compare the firmware version shown on the device with these numbers and confirm whether IPsec VPN is configured.Source: certvde.com

How do I fix CVE-2026-105982?

Update TK100 to firmware 3.5.116, TK500-v2 to 1.0.124, or TK500-v3 to 1.0.123, or any later release. No workaround is listed in the facts.Source: certvde.com