Skip to main content
← Vulnerabilities

Command Injection in WireGuard VPN

Welotec TK102L, TK102W and TK100 below 3.5.116, TK500-v2 models below 1.0.124, and TK500-v3 models below 1.0.123 are affected when the WireGuard VPN function is in use. The fixed versions are listed as the update targets.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.6HighCNA
Exploited
No known exploitation
Fix
Fixed in 3.5.116, 1.0.124, 1.0.123
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Welotec TK102L, TK102W and TK100 routers below version 3.5.116 Welotec TK525L-v2, TK525L-W-v2, TK525W-v2, TK535L1-v2 (TK500-v2) routers below version 1.0.124 Welotec TK525L-v3, TK525L-W-G-v3, TK525L-IO-v3, TK525L-W-v3, TK525W-v3, TK555L-v3 (TK500-v3) routers below version 1.0.123 The WireGuard VPN function is in use

18Pcve.now Index 18 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity9.6/10CVSS 8.6, total technical impact per CISA
  • No patch0/5No signal

What would change the score

  • Would score about 68 if added to CISA KEV
  • Would score about 63 if CISA's SSVC rates exploitation active
  • Would score about 25 if CISA's SSVC rates it automatable

CVE-2026-105980 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects TK100, TK500-v2 and TK500-v3; fixed in 3.5.116, 1.0.124 and 1.0.123.

Published
Last modified
Published
Not listed in CISA KEV
0.36% · 29th percentile
18/100 · provisional
Specific setups only
Fix
Fixed in 3.5.116, 1.0.124, 1.0.123
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

The WireGuard VPN function is affected by this vulnerability, which stems from improper input validation. A remote attacker with high privileges could exploit it to run arbitrary system commands with root-level access.

Read the original description

Improper input validation in the WireGuard VPN function may allow a remote attacker with high privileges to inject system commands and execute them with root privileges.

What to do

  • Check whether your setup matches what the bug needs.

    Welotec TK102L, TK102W and TK100 routers below version 3.5.116 Welotec TK525L-v2, TK525L-W-v2, TK525W-v2, TK535L1-v2 (TK500-v2) routers below version 1.0.124 Welotec TK525L-v3, TK525L-W-G-v3, TK525L-IO-v3, TK525L-W-v3, TK525W-v3, TK555L-v3 (TK500-v3) routers below version 1.0.123 The WireGuard VPN function is in use
  • Upgrade to a fixed version: 3.5.116, 1.0.124, 1.0.123.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  4. Record last updated

Affected versions

  • Welotec TK100

    From 0.0.0 · fixed in 3.5.116

  • Welotec TK500-v2

    From 0.0.0 · fixed in 1.0.124

  • Welotec TK500-v3

    From 0.0.0 · fixed in 1.0.123

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-105980

Is CVE-2026-105980 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Improper input validation in the WireGuard VPN function allows an attacker to inject system commands. Those commands run with root privileges, which gives the attacker full control of the device.Source: certvde.com

Which versions are affected by CVE-2026-105980?

TK100: from 0.0.0 before 3.5.116. TK500-v2: from 0.0.0 before 1.0.124. TK500-v3: from 0.0.0 before 1.0.123.Source: cve.now feed data

Am I affected, and how do I check?

Welotec TK102L, TK102W and TK100 routers below 3.5.116, TK525L-v2, TK525L-W-v2, TK525W-v2 and TK535L1-v2 (TK500-v2) routers below 1.0.124, and TK525L-v3, TK525L-W-G-v3, TK525L-IO-v3, TK525L-W-v3, TK525W-v3 and TK555L-v3 (TK500-v3) routers below 1.0.123 are listed. The WireGuard VPN function must be in use. Check the firmware version in the device's web interface and whether WireGuard VPN is enabled.Source: certvde.com

How do I fix CVE-2026-105980?

Update TK102L, TK102W and TK100 to 3.5.116 or later, TK500-v2 models to 1.0.124 or later, and TK500-v3 models to 1.0.123 or later.Source: certvde.com