Skip to main content
← Vulnerabilities

Command Injection in ZeroTier VPN

Welotec TK100 before 3.5.116, TK500-v2 before 1.0.124, and TK500-v3 before 1.0.123 with the ZeroTier VPN function are affected. Fixed in the listed versions.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.6HighCNA
Exploited
No known exploitation
Fix
Fixed in 3.5.116, 1.0.124, 1.0.123
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Welotec routers with the ZeroTier VPN function

17Pcve.now Index 17 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity8.6/10CVSS 8.6
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 24 if CISA's SSVC rates it automatable

CVE-2026-105979 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects TK100, TK500-v2 and TK500-v3; fixed in 3.5.116, 1.0.124 and 1.0.123.

Published
Last modified
Published
Not listed in CISA KEV
0.36% · 29th percentile
17/100 · provisional
Specific setups only
Fix
Fixed in 3.5.116, 1.0.124, 1.0.123
None on Exploit-DB, Metasploit or GitHub

Summary

ZeroTier VPN software is affected by this vulnerability, which could allow a remote attacker who already has high-level privileges to run arbitrary system commands. Because those commands run with root privileges, an attacker could gain full control over the affected system.

Read the original description

Improper input validation in the ZeroTier VPN function may allow a remote attacker with high privileges to inject system commands and execute them with root privileges.

What to do

  • Check whether your setup matches what the bug needs.

    Welotec routers with the ZeroTier VPN function
  • Upgrade to a fixed version: 3.5.116, 1.0.124, 1.0.123.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • Welotec TK100

    From 0.0.0 · fixed in 3.5.116

  • Welotec TK500-v2

    From 0.0.0 · fixed in 1.0.124

  • Welotec TK500-v3

    From 0.0.0 · fixed in 1.0.123

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-105979

Is CVE-2026-105979 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Improper input validation in the ZeroTier VPN function may let a remote attacker with high privileges inject system commands. Those commands run with root privileges.Source: certvde.com

Which versions are affected by CVE-2026-105979?

TK100: from 0.0.0 before 3.5.116. TK500-v2: from 0.0.0 before 1.0.124. TK500-v3: from 0.0.0 before 1.0.123.Source: cve.now feed data

Am I affected, and how do I check?

Welotec TK100 before 3.5.116, TK500-v2 before 1.0.124, and TK500-v3 before 1.0.123 with the ZeroTier VPN function. Check the firmware version on the device and whether the ZeroTier VPN function is in use.Source: certvde.com

How do I fix CVE-2026-105979?

Update to TK100 3.5.116, TK500-v2 1.0.124, or TK500-v3 1.0.123, or a later release of the same model line.Source: certvde.com