Skip to main content
← Vulnerabilities

Command Injection in Management Control Functions

Welotec TK102L, TK102W and TK100 routers before 3.5.116, TK500-v2 routers before 1.0.124 and TK500-v3 routers before 1.0.123 are affected. Upgrading to those versions fixes the issue.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.6HighCNA
Exploited
No known exploitation
Fix
Fixed in 3.5.116, 1.0.124, 1.0.123
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Welotec TK102L, TK102W and TK100 routers with versions before 3.5.116 Welotec TK500-v2 based routers (TK525L-v2, TK525L-W-v2, TK525W-v2, TK535L1-v2) with versions before 1.0.124 Welotec TK500-v3 based routers (TK525L-v3, TK525L-W-G-v3, TK525L-IO-v3, TK525L-W-v3, TK525W-v3, TK555L-v3) with versions before 1.0.123

17Pcve.now Index 17 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity8.6/10CVSS 8.6
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 24 if CISA's SSVC rates it automatable

CVE-2026-105978 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.6 (high) and affects TK100, TK500-v2 and TK500-v3; fixed in 3.5.116, 1.0.124 and 1.0.123.

Published
Last modified
Published
Not listed in CISA KEV
0.36% · 29th percentile
17/100 · provisional
Specific setups only
Fix
Fixed in 3.5.116, 1.0.124, 1.0.123
None on Exploit-DB, Metasploit or GitHub

Summary

This vulnerability affects the management control functions of a software product, which is affected by improper input validation. A remote attacker who already holds high privileges could exploit it to run arbitrary operating system commands with root-level access.

Read the original description

Improper input validation in management control functions may allow a remote attacker with high privileges to inject operating system commands and execute them with root privileges.

What to do

  • Check whether your setup matches what the bug needs.

    Welotec TK102L, TK102W and TK100 routers with versions before 3.5.116 Welotec TK500-v2 based routers (TK525L-v2, TK525L-W-v2, TK525W-v2, TK535L1-v2) with versions before 1.0.124 Welotec TK500-v3 based routers (TK525L-v3, TK525L-W-G-v3, TK525L-IO-v3, TK525L-W-v3, TK525W-v3, TK555L-v3) with versions before 1.0.123
  • Upgrade to a fixed version: 3.5.116, 1.0.124, 1.0.123.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • Welotec TK100

    From 0.0.0 · fixed in 3.5.116

  • Welotec TK500-v2

    From 0.0.0 · fixed in 1.0.124

  • Welotec TK500-v3

    From 0.0.0 · fixed in 1.0.123

Evidence 1

  1. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-105978

Is CVE-2026-105978 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Improper input validation in the management control functions lets a remote attacker with high privileges inject operating system commands. The injected commands run with root privileges, which gives full control of the device.Source: certvde.com

Which versions are affected by CVE-2026-105978?

TK100: from 0.0.0 before 3.5.116. TK500-v2: from 0.0.0 before 1.0.124. TK500-v3: from 0.0.0 before 1.0.123.Source: cve.now feed data

Am I affected, and how do I check?

Welotec TK102L, TK102W and TK100 routers before 3.5.116, TK500-v2 based routers (TK525L-v2, TK525L-W-v2, TK525W-v2, TK535L1-v2) before 1.0.124, and TK500-v3 based routers (TK525L-v3, TK525L-W-G-v3, TK525L-IO-v3, TK525L-W-v3, TK525W-v3, TK555L-v3) before 1.0.123. Check the firmware version installed on the device and compare it with these versions.Source: certvde.com

How do I fix CVE-2026-105978?

Upgrade TK100 routers to 3.5.116 or later, TK500-v2 routers to 1.0.124 or later, and TK500-v3 routers to 1.0.123 or later.Source: certvde.com