Skip to main content
← All vulnerabilities
CVE-2026-105894EUVD-2026-114234GHSA-RQ7C-4VHW-WV57

Ak Framework <= 2.9.8 - Authenticated (Subscriber+) Missing Authorization to Arbitrary Options Update

Ak Framework versions up to and including 2.9.8 are affected, particularly on sites that allow registration or access by non-administrator users. The fix is in 2.9.9.

Published
Last modified
published
Not listed in CISA KEV
Specific setups only
Fix
Fixed in 2.9.9
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

The Ak Framework plugin for WordPress, which is bundled with the Newsy - Viral News & Magazine WordPress theme, is affected by this flaw. An attacker can abuse it to change arbitrary site settings, such as enabling user registration and setting the default role to administrator, which can lead to full administrative control of the site.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

The Ak Framework plugin for WordPress, included in the Newsy - Viral News & Magazine WordPress Theme, is vulnerable to Privilege Escalation in all versions up to, and including, 2.9.8. This is due to missing capability checks in the ajax_refresh_nonce and ak_admin_ajax handlers before passing attacker-controlled option names and values to update_option(). This makes it possible for unauthenticated attackers to update arbitrary WordPress options including users_can_register and default_role to escalate privileges to administrator by enabling user registration with administrator as the default role.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  4. Record last updated

Affected versions

  • akbilisim Ak Framework

    through 2.9.8

References 2

wordfence.com

docs.akbilisim.com

FAQ

Questions about CVE-2026-105894

What does this mean?

A flaw in Ak Framework's options update lets an authenticated user gain privileges they should not have, because the update is missing an authorization check. The advisory describes it as a privilege-escalation vulnerability.Source: docs.akbilisim.com

Am I affected, and how do I check?

All Ak Framework versions up to and including 2.9.8 are in the affected range. To check an installation, compare the installed Ak Framework version against 2.9.8 or earlier.Source: docs.akbilisim.com

What should I do about it?

Update Ak Framework to version 2.9.9 or later, the version the vendor lists as the fix. The advisory particularly recommends updating on sites that allow registration or access by non-administrator users.Source: docs.akbilisim.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Why do the sources disagree?

The sources differ on the attack requirements. One description points to an unauthenticated vector, while the CVSS vector records PR:L, which means low privileges are required.Source: docs.akbilisim.com