Skip to main content
← All vulnerabilities
CVE-2026-105133

Ahsay AhsayCBS API ApiStructsAction.java checkSysPwd improper authentication

AhsayCBS versions up through 10.3.4 are affected, including 9.15.2.69 and 10.3.4.44. The fix is in 10.3.4.45.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 10.3.4.45
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: active
  • Automatable: yes
  • Technical impact: partial

Summary

Ahsay AhsayCBS, a backup and recovery platform, is affected through its API component, where improper authentication in the system password check could let a remote attacker bypass login protections. Successful exploitation could allow unauthorized access to the affected backup system.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

A vulnerability was detected in Ahsay AhsayCBS up to 9.15.2.69/10.3.4.44. This affects the function checkSysPwd of the file com/ahsay/obs/api/ApiStructsAction.java of the component API. Performing a manipulation of the argument random results in improper authentication. It is possible to initiate the attack remotely. The exploit is now public and may be used. Upgrading to version 9.15.2.70 and 10.3.4.45 is able to mitigate this issue. It is recommended to upgrade the affected component. The initial patch did not fix the security vulnerability properly. An update of the CVE entry to reflect this became necessary.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: active · Automatable: yes · Technical impact: partial

  3. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  4. CISA remediation deadline

    Due date for US federal agencies to patch

  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

  6. Record last updated

Affected versions

  • Ahsay AhsayCBS

    9.15.2.0, 9.15.2.1, 9.15.2.2, 9.15.2.3, 9.15.2.4, 9.15.2.5, 9.15.2.6, 9.15.2.7, 9.15.2.8, 9.15.2.9, 9.15.2.10, 9.15.2.11, 9.15.2.12, 9.15.2.13, 9.15.2.14, 9.15.2.15, 9.15.2.16, 9.15.2.17, 9.15.2.18, 9.15.2.19, 9.15.2.20, 9.15.2.21, 9.15.2.22, 9.15.2.23, 9.15.2.24, 9.15.2.25, 9.15.2.26, 9.15.2.27, 9.15.2.28, 9.15.2.29, and 85 more

References 7

VulDB

ahsay.com

huntress.com

FAQ

Questions about CVE-2026-105133

What does this mean?

A flaw in the checkSysPwd function of ApiStructsAction.java allows authentication to the AhsayCBS management interface to be bypassed. That bypass is the initial entry point in a chain that leads to remote code execution.Source: huntress.com, ahsay.com

Am I affected, and how do I check?

AhsayCBS versions up through 10.3.4 are affected, including 9.15.2.69 and 10.3.4.44. Compare the installed AhsayCBS version number against that range to check whether a given installation falls within it.Source: huntress.com, ahsay.com

What should I do about it?

Apply the AhsayCBS v10.3.4.45 hotfix, which the vendor provides for affected v10 versions. Until it is applied, restrict access to the management interface.Source: huntress.com, ahsay.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-10-14, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data