WordPress Ad Inserter plugin <= 2.8.19 - Cross Site Scripting (XSS) vulnerability
Affects the Ad Inserter WordPress plugin, version 2.8.19 and earlier. The vendor's fix is in version 2.8.20.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 2.8.20
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
The Ad Inserter plugin for WordPress is affected by this vulnerability. An unauthenticated attacker can inject malicious scripts that run in the browsers of users who visit a crafted page, potentially allowing them to steal session data or perform actions on the affected site.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Unauthenticated Cross Site Scripting (XSS) in Ad Inserter <= 2.8.19 versions.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- ad-inserter
through 2.8.19
References 1
Questions about CVE-2026-105077
What does this mean?
The flaw is cross-site scripting (XSS). Attackers can inject malicious scripts into the site that steal visitor data or hijack visitors' accounts.Source: patchstack.com
Am I affected, and how do I check?
The Ad Inserter WordPress plugin, version 2.8.19 or earlier, is listed as vulnerable. To check, look at the installed plugin version on the WordPress Plugins page.Source: patchstack.com
What should I do about it?
Update the Ad Inserter plugin to version 2.8.20 or later.Source: patchstack.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data