WarehousePG (WHPG) 6.27.1 through 6.27.6 and 7.2.1 through 7.6.0 are affected by a missing authorization vulnerability (CWE-862) in the…
Affects WarehousePG 6.27.1 through 6.27.6 and 7.2.1 through 7.6.0, with fixes in 6.27.7 and 7.6.1. Upgrading to a fixed version is the remedy.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 6.27.7, 7.6.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
WarehousePG (WHPG) 6.27.1 through 6.27.6 and 7.2.1 through 7.6.0 are affected by a missing authorization vulnerability (CWE-862) in the built-in cluster expansion functions gp_expand_lock_catalog() and gp_expand_bump_version(). Any authenticated database role can run them, and neither checks privileges. A low-privileged user can call gp_expand_lock_catalog() inside an open transaction to block all catalog changes across the cluster for every user, superusers included, until that transaction ends, which in practice requires a superuser to terminate the session. Blocked changes include DDL, temporary table creation, GRANT and CREATE ROLE. The same user can call gp_expand_bump_version() repeatedly. Each call disconnects sessions that hold temporary tables, with a FATAL error on their next catalog change, and makes every other session rebuild its segment connections.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- EnterpriseDB WarehousePG
From 6.27.1 · fixed in 6.27.7; From 7.2.1 · fixed in 7.6.1
References 1
enterprisedb.com
Questions about CVE-2026-104948
What does this mean?
A low-privileged authenticated user can block all catalog changes across the cluster for every user, including superusers, until their transaction ends. The same user can also disconnect sessions holding temporary tables and force other sessions to rebuild segment connections.Source: enterprisedb.com
Am I affected, and how do I check?
Versions 6.27.1 through 6.27.6 and 7.2.1 through 7.6.0 are affected. Compare the installed WarehousePG version against these ranges, and note that the relevant functions are gp_expand_lock_catalog() and gp_expand_bump_version().Source: enterprisedb.com
What should I do about it?
Upgrade to WarehousePG 6.27.7 or 7.6.1, or a later fixed version. Until then, a superuser can revoke EXECUTE on gp_expand_lock_catalog() and gp_expand_bump_version() from public in every connectable database.Source: enterprisedb.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data