Use-after-free vulnerability in GitHub Enterprise Server allowed remote code execution in the Git service
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 3.19.14, 3.20.10, 3.21.8, 3.22.3
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 3.19.14, 3.20.10, 3.21.8, 3.22.3.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure3/25Reachable over the network · Data gap: No advisory context yet
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity7.7/10CVSS 7.7
- No patch0/5No signal
What would change the score
- Would score about 66 if added to CISA KEV
- Would score about 61 if CISA's SSVC rates exploitation active
- Would score about 30 if advisories confirm default setups are exposed
CVE-2026-104608 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.7 (high) and affects Enterprise Server; fixed in 3.19.14, 3.20.10, 3.21.8 and 1 more.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 11/100 · provisional
- Fix
- Fixed in 3.19.14, 3.20.10, 3.21.8, 3.22.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
GitHub Enterprise Server's Git service (babeld) could be abused by an authenticated user with SSH access to run arbitrary commands on the server and expose its environment secrets. The flaw was a use-after-free bug, and it affected all releases prior to the fixed versions.
Read the original description
A remote code execution vulnerability was identified in GitHub Enterprise Server in the Git service (babeld). babeld held references into internal collections while calling into the SSH library, where a re-entrant callback could modify a collection and invalidate those references. An attacker with an account and SSH access to the instance could leverage this use-after-free into a controlled write and run arbitrary commands as babeld, including disclosure of its environment secrets. Exploitation required per-build memory offsets; failed attempts crashed babeld. This affected all releases prior to 3.23 and was fixed in 3.22.3, 3.21.8, 3.20.10, and 3.19.14. This vulnerability was reported via the GitHub Bug Bounty program.
What to do
Upgrade to a fixed version: 3.19.14, 3.20.10, 3.21.8, 3.22.3.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- GitHub Enterprise Server
From 3.19.0 · fixed in 3.19.14; From 3.20.0 · fixed in 3.20.10; From 3.21.0 · fixed in 3.21.8; From 3.22.0 · fixed in 3.22.3
Evidence 4
- Link
- Link
- Link
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-104608
Is CVE-2026-104608 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-104608?
Enterprise Server: from 3.19.0 before 3.19.14; from 3.20.0 before 3.20.10; from 3.21.0 before 3.21.8; from 3.22.0 before 3.22.3.Source: cve.now feed data
How do I fix CVE-2026-104608?
Upgrade to a fixed version: 3.19.14, 3.20.10, 3.21.8, 3.22.3.Source: cve.now feed data