Langflow OSS is affected by multiple vulnerabilities
Affects IBM Langflow OSS versions 1.0.0 through 1.12.3 where an attacker can reach the message broker. Fixed in 1.12.4.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 1.12.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
IBM Langflow OSS, an open-source tool for building AI workflows, is affected by this vulnerability. A remote attacker who can reach its message broker could run arbitrary code on the affected system.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote attacker who could reach the message broker to execute arbitrary code on the system due to the deserialization of untrusted data.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- IBM Langflow OSS
From 1.0.0 · through 1.12.3
References 1
ibm.com
Questions about CVE-2026-104317
What does this mean?
The flaw comes from deserializing untrusted data, which can let an attacker execute arbitrary code on the affected system.Source: ibm.com
Am I affected, and how do I check?
Langflow OSS versions 1.0.0 through 1.12.3 are in scope. The advisory's condition is that an attacker must be able to reach the message broker, so check the installed version and whether the message broker is reachable from untrusted networks.Source: ibm.com
What should I do about it?
IBM strongly recommends upgrading Langflow OSS to version 1.12.4 now.Source: ibm.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data