Skip to main content
← Vulnerabilities

Control Web Panel (CWP) < 1.30 OS Command Injection via valid_token

Affects Control Web Panel (CWP) versions before 1.30 through an unvalidated 'user' parameter on the loopback API /valid_token/ route. Fixed in 1.30.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.6HighCNA
Exploited
No known exploitation
Fix
Fixed in 1.30
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Control Web Panel versions before 1.30 Unvalidated 'user' parameter on the loopback API /valid_token/ route

Published
Last modified
Published
Not listed in CISA KEV
14/100 · provisional
Specific setups only
Fix
Fixed in 1.30
None on Exploit-DB, Metasploit or GitHub

Summary

Control Web Panel (CWP), a web-based server administration tool, is affected, allowing unauthenticated attackers to run arbitrary system commands with root privileges on the underlying server. Successful exploitation would give an attacker full control over the affected system.

Read the original description

Control Web Panel (CWP) before webpanel_version 1.30 contains an OS command injection vulnerability in the loopback API /valid_token/ route that allows unauthenticated attackers to execute arbitrary commands as root by injecting shell metacharacters into the unvalidated 'user' parameter. Attackers can send a crafted request to the /valid_token/ route, which passes the parameter unescaped into a shell_exec() call.

What to do

  • Check whether your setup matches what the bug needs.

    Control Web Panel versions before 1.30 Unvalidated 'user' parameter on the loopback API /valid_token/ route
  • Upgrade to a fixed version: 1.30.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. Record last updated

Affected versions

  • Control Web Panel Control Web Panel

    fixed in 1.30

Evidence 3

  1. Patch
  2. Exploit
  3. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-104080

What does this mean?

The 'user' parameter on the loopback API /valid_token/ route is not validated, which allows arbitrary OS commands to run as root on the underlying system.Source: vulncheck.com

Am I affected, and how do I check?

Control Web Panel (CWP) versions before 1.30 are affected. The version is reported as webpanel_version, so check that value on the installation.Source: vulncheck.com

What should I do about it?

Upgrade Control Web Panel to version 1.30 or later, which contains the fix.Source: vulncheck.com

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data