Scribus before 1.6.7 Heap Out-of-Bounds Write via PSD Image Loader
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 1.6.7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Scribus, an open-source desktop publishing application, is affected through its PSD image loader, which can be tricked by a specially crafted Photoshop file into writing data outside a memory buffer. This can crash the application or potentially allow an attacker to run code with the user's privileges.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Scribus before 1.6.7 contains a heap out-of-bounds write vulnerability in the scimgdataloader_psd loader that uses unchecked PSD file values as lookup array indexes. Attackers can convince users to place or import a crafted PSD file to corrupt heap memory, causing crashes and potentially code execution as the user.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- Scribus Scribus
fixed in 1.6.7
References 4
GitHub · scribusproject/scribus
wiki.scribus.net
Questions about CVE-2026-104061
What does this mean?
A crafted PSD (Photoshop) file can make Scribus write and read memory outside the area it allocated for an image. This memory corruption can crash Scribus, and the facts say it could lead to something worse.Source: wiki.scribus.net
Am I affected, and how do I check?
Scribus versions before 1.6.7 are affected, with the PSD image loader involved when a PSD file is placed in an image frame or imported. To check, look at the Scribus version under Help > About; a version below 1.6.7 falls in the affected range.Source: wiki.scribus.net
What should I do about it?
Upgrade Scribus to version 1.6.7 or later, which is the fixed release. The advisory strongly encourages all users of the 1.6.x line to upgrade.Source: wiki.scribus.net
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data