Langflow OSS is affected by multiple vulnerabilities
Langflow OSS versions 1.0.0 through 1.12.3 are affected. Upgrading to 1.12.4 fixes the issue. The sources do not give a vendor severity rating.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 1.12.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
IBM Langflow OSS is affected, and a logged-in remote attacker could exploit improper access control to run arbitrary SQL commands against the database. This could allow the attacker to read, modify, or delete data beyond what they should be permitted to access.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated attacker to execute arbitrary SQL commands due to improper access control.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- IBM Langflow OSS
From 1.0.0 · through 1.12.3
References 1
ibm.com
Questions about CVE-2026-103092
What does this mean?
The sources name multiple vulnerabilities in Langflow OSS but do not describe what each flaw does. The available facts do not give the impact.Source: ibm.com
Am I affected, and how do I check?
Langflow OSS versions 1.0.0 through 1.12.3 are in the affected range. To check an installation, look up the installed Langflow OSS version and compare it with that range.Source: ibm.com
What should I do about it?
Upgrade Langflow OSS to version 1.12.4, which the advisory names as the fix. No workaround is listed in the facts.Source: ibm.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data