Skip to main content
← Vulnerabilities

GPUStack: Missing authorization on several cluster and resource endpoints allows cross-user access and cluster takeover

Affects GPUStack 2.2.0 before 2.2.2 when a Kubernetes-provider cluster has a reachable worker. Fixed in 2.2.2.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

8.8HighCNA
Exploited
No known exploitation
Fix
Fixed in 2.2.2
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Kubernetes-provider cluster with a reachable worker

17Pcve.now Index 17 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity8.8/10CVSS 8.8
  • No patch0/5No signal

What would change the score

  • Would score about 67 if added to CISA KEV
  • Would score about 62 if CISA's SSVC rates exploitation active
  • Would score about 24 if CISA's SSVC rates it automatable

CVE-2026-103002 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects gpustack; fixed in 2.2.2.

Published
Last modified
Published
Not listed in CISA KEV
17/100 · provisional
Specific setups only
Fix
Fixed in 2.2.2
None on Exploit-DB, Metasploit or GitHub

Summary

GPUStack, an open-source GPU cluster manager for AI model serving, has missing authorization checks on its cluster API proxy that affect versions 2.2.0 through 2.2.2. An authenticated low-privilege user can remotely reach Kubernetes clusters they should not access and read, change, or delete resources using a worker's ServiceAccount permissions, and this can lead to code execution in the target cluster when the cluster uses a Kubernetes provider with a reachable worker.

Read the original description

GPUStack is an open-source GPU cluster manager for AI model serving and GPU instance provisioning. From 2.2.0 until 2.2.2, cluster_apiserver_proxy forwarded an authenticated non-administrator's requests to a selected Kubernetes cluster without a resource-level authorization check. The proxy used a reachable worker's Kubernetes ServiceAccount credentials, so the caller could read sensitive resources, create or modify workloads, or delete resources according to that ServiceAccount's permissions. Exploitation required a Kubernetes-provider cluster with a reachable worker, and attacker-controlled workloads could result in code execution in the target cluster. This issue is fixed in version 2.2.2.

What to do

  • Check whether your setup matches what the bug needs.

    Kubernetes-provider cluster with a reachable worker
  • Upgrade to a fixed version: 2.2.2.

  • Workaround: Restrict access to the GPUStack instance to trusted administrator accounts until upgrading.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • gpustack gpustack

    From 2.2.0 · fixed in 2.2.2

Evidence 6

  1. Advisory
  2. Repository
  3. Repository
  4. Repository
  5. Repository
  6. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-103002

Is CVE-2026-103002 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

Several cluster and resource endpoints in GPUStack do not check authorization, so one user can reach resources that belong to others and take over a cluster. Depending on the permissions of the worker's ServiceAccount, the impact can include reading sensitive Kubernetes resources, creating or changing workloads, deleting resources, and running code in the target cluster.Source: github.com

Which versions are affected by CVE-2026-103002?

gpustack: from 2.2.0 before 2.2.2.Source: cve.now feed data

Am I affected, and how do I check?

GPUStack versions from 2.2.0 up to but not including 2.2.2 are in the affected range. The affected setup is a Kubernetes-provider cluster with a reachable worker, so check the installed GPUStack version and whether any cluster uses the Kubernetes provider with a reachable worker.Source: github.com

How do I fix CVE-2026-103002?

Upgrade GPUStack to 2.2.2, the fixed version. Until the upgrade is done, restrict access to the GPUStack instance to trusted administrator accounts.Source: github.com