ESPectre: Unsafe Deserialization on .npz dataset leads to Code Execution
Affects ESPectre versions before 3.0.0-rc1, including 2.8.0, when analysis tools load CSI dataset .npz files with NumPy pickle support enabled. Fixed in 3.0.0-rc1.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 3.0.0-rc1
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. Analysis tools load CSI dataset .npz files with NumPy pickle support enabled (allow_pickle=True). The malicious .npz file must contain an object-typed array, and the code runs when a documented analysis tool runs. Affected versions are those before 3.0.0-rc1 (version 2.8.0 is affected).
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 13/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
ESPectre, a Wi-Fi motion sensing platform for ESP32, has an unsafe deserialization flaw in its Micro-ESPectre analysis tools that lets an attacker run code as the maintainer or developer. An attacker can reach it locally without logging in, but a user must run an affected tool on a malicious .npz dataset, such as one submitted through a pull request.
Read the original description
ESPectre is a Wi-Fi motion sensing platform for ESP32. Prior to 3.0.0-rc1, Micro-ESPectre analysis tools, including tools/6_optimize_filter_params.py, tools/1_analyze_raw_data.py, and tools/10_train_ml_model.py, load NPZ datasets with NumPy pickle support enabled through micro-espectre/tools/csi_utils.py and a direct loader. A malicious dataset contributor or pull-request author can place an object-typed array in a .npz file under micro-espectre/data, causing pickle-controlled code to execute as the maintainer or developer when a documented analysis tool accesses the field. This issue is fixed in version 3.0.0-rc1.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure5/25Specific setups only
- Reach?/20Unknown. No tracked technology or package matched
- Severity7.8/10CVSS 7.8
- No patch0/5No signal
What would change the score
- Would score about 63 if added to CISA KEV
- Would score about 58 if CISA's SSVC rates exploitation active
- Would score about 23 if CISA's SSVC rates it automatable
What to do
Check whether your setup matches what the bug needs.
Analysis tools load CSI dataset .npz files with NumPy pickle support enabled (allow_pickle=True). The malicious .npz file must contain an object-typed array, and the code runs when a documented analysis tool runs. Affected versions are those before 3.0.0-rc1 (version 2.8.0 is affected).Upgrade to a fixed version: 3.0.0-rc1.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- francescopace espectre
fixed in 3.0.0-rc1
Evidence 4
- Advisory
- Repository
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-102739
Is CVE-2026-102739 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A crafted .npz file containing an object-typed array can run attacker-supplied pickle code when a documented analysis tool loads it. The code runs as the user who ran the analysis command.Source: github.com
Which versions are affected by CVE-2026-102739?
espectre: before 3.0.0-rc1.Source: cve.now feed data
Am I affected, and how do I check?
Versions before 3.0.0-rc1 are affected, and the advisory confirms version 2.8.0. The vulnerable setup is analysis tools that call np.load with allow_pickle=True on CSI dataset files; the version can be checked in the project's release metadata, and the setting can be checked by searching the analysis code for allow_pickle=True.Source: github.com
How do I fix CVE-2026-102739?
Upgrade ESPectre to 3.0.0-rc1 or a later release. The advisory names 3.0.0-rc1 as the fixed version.Source: github.com