Skip to main content
← Vulnerabilities

ProxySQL: Uninitialized heap read in MySQL compressed packet decompression via zlib path

Affects ProxySQL before 3.0.10, 3.1.0 to 3.1.9, and 4.0.0 to 4.0.9 where clients use MySQL compression, which is on by default. Fixed in 3.0.10, 3.1.10 and 4.0.10.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.1HighCNA
Exploited
No known exploitation
Fix
Fixed in 3.0.10, 3.1.10, 4.0.10
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Client negotiates compression (CLIENT_COMPRESS flag), which is enabled by default The zlib decompression path is used

15Pcve.now Index 15 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity7.1/10CVSS 7.1
  • No patch0/5No signal

What would change the score

  • Would score about 65 if added to CISA KEV
  • Would score about 60 if CISA's SSVC rates exploitation active
  • Would score about 22 if CISA's SSVC rates it automatable

CVE-2026-102664 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects proxysql; fixed in 3.0.10, 3.1.10 and 4.0.10.

Published
Last modified
Published
Not listed in CISA KEV
15/100 · provisional
Specific setups only
Fix
Fixed in 3.0.10, 3.1.10, 4.0.10
None on Exploit-DB, Metasploit or GitHub

Summary

ProxySQL, a proxy for MySQL, PostgreSQL and their forks, has an uninitialized heap read in its zlib-based decompression of MySQL compressed packets. An attacker who can reach the service over the network with a low-privilege authenticated MySQL client that negotiates compression can make ProxySQL forward stale memory from the backend, potentially exposing prior SQL queries, result data, credentials, or session state.

Read the original description

ProxySQL is a proxy for MySQL and its forks, as well as PostgreSQL. Prior to 3.0.10, 3.1.10, and 4.0.10, decompress_mysql_payload() in lib/mysql_data_stream.cpp accepts a zlib stream when uncompress() returns Z_OK without checking that the actual output length equals the attacker-controlled payload_length. An authenticated MySQL client that negotiates compression can overstate payload_length, causing buffer2array() to parse the uninitialized tail of a heap buffer as MySQL packet headers and forward stale data to the backend. Backend error responses can disclose prior SQL queries, result data, credentials, or session state, and malformed lengths can also cause excessive allocations. This issue is fixed in versions 3.0.10, 3.1.10, and 4.0.10.

What to do

  • Check whether your setup matches what the bug needs.

    Client negotiates compression (CLIENT_COMPRESS flag), which is enabled by default The zlib decompression path is used
  • Upgrade to a fixed version: 3.0.10, 3.1.10, 4.0.10.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • sysown proxysql

    fixed in 3.0.10; From 3.1.0 · fixed in 3.1.10; From 4.0.0 · fixed in 4.0.10

Evidence 6

  1. Advisory
  2. Repository
  3. Repository
  4. Repository
  5. Repository
  6. Repository

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-102664

Is CVE-2026-102664 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

ProxySQL can read uninitialized heap memory while decompressing MySQL compressed packets on the zlib path. That memory may hold SQL queries, result set data, credentials, or session state from other users' connections. The flaw can also allow denial of service through excessive allocations.Source: github.com

Which versions are affected by CVE-2026-102664?

proxysql: before 3.0.10; from 3.1.0 before 3.1.10; from 4.0.0 before 4.0.10.Source: cve.now feed data

Am I affected, and how do I check?

Versions before 3.0.10, from 3.1.0 before 3.1.10, and from 4.0.0 before 4.0.10 are in the affected range. The bug needs a client to negotiate compression (CLIENT_COMPRESS) and the zlib path to be used, and compression is enabled by default through mysql-have_compress=true, so check the ProxySQL version and that variable.Source: github.com

How do I fix CVE-2026-102664?

Upgrade to 3.0.10, 3.1.10, or 4.0.10, depending on which release line is in use. Those releases are the listed fixed versions.Source: github.com