Skip to main content
← All vulnerabilities
CVE-2026-102489

Undisclosed RCE in Zammad v6.3 and higher

Affects Zammad 6.5 and earlier versions because of the runtime environment those versions use. The fix is included in Zammad 7.2.0. Zammad has not published a vendor severity rating.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 6.5.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: active
  • Automatable: no
  • Technical impact: total

Summary

Zammad, an open-source help desk and ticketing application, is affected by a flaw that allows an attacker to hijack a user's session and then execute code on the server with the privileges of the Zammad service account. Some later releases contain the same bug but are not exploitable because of changes in the underlying framework.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Zammad versions 6.3.0 to 6.5.4 are vulnerable a session hijack vulnerability that leads to remote code execution as the zammad user. The bug is also present in version 7.0.0 to version 7.1.2, but not exploitable due to changes in the underlying framework.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: active · Automatable: no · Technical impact: total

  3. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  4. CISA remediation deadline

    Due date for US federal agencies to patch

  5. Record last updated
  6. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Zammad GmbH Zammad

    From 6.3.0 · fixed in 6.5.4

References 4

csirt.divd.nl

zammad.com

community.zammad.org

FAQ

Questions about CVE-2026-102489

What does this mean?

The title describes this as an undisclosed remote code execution (RCE) flaw in Zammad. The checked facts do not describe the technical details of the bug.Source: zammad.com

Am I affected, and how do I check?

The product range lists Zammad 6.3.0 up to 6.5.4, while the advisory condition says Zammad 6.5 and earlier versions are affected due to their runtime environment. Compare your installed Zammad version against both statements.Source: zammad.com

What should I do about it?

Upgrade to Zammad 7.2.0, which the advisory says includes the fix.Source: zammad.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-10-02, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data