Langflow OSS is affected by multiple vulnerabilities
Affects IBM Langflow OSS versions 1.0.0 through 1.12.3. CVSS rates it high at 8.8, and no vendor severity is given. Fixed in 1.12.4.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 1.12.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
IBM Langflow OSS, an open-source tool for building AI workflows, is affected by flaws that could let a remote attacker who has valid login credentials run arbitrary code on the system. Successful exploitation could allow the attacker to take control of the affected host.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
IBM Langflow OSS 1.0.0 through 1.12.3 could allow a remote authenticated attacker to execute arbitrary code due to improper neutralization of special elements used in code.
Timeline
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- CVE published
- First seen by cve.now
- Record last updated
Affected versions
- IBM Langflow OSS
From 1.0.0 · through 1.12.3
References 1
ibm.com
Questions about CVE-2026-101288
What does this mean?
The flaw could allow a remote authenticated attacker to execute arbitrary code on the affected system.Source: ibm.com
Am I affected, and how do I check?
Langflow OSS versions 1.0.0 through 1.12.3 are in the affected range. To check an installed copy, look up its Langflow OSS version and compare it against that range.Source: ibm.com
What should I do about it?
Upgrade Langflow OSS to version 1.12.4, which IBM strongly recommends doing now.Source: ibm.com
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data