SuiteCRM: Privilege escalation via V8 REST modules (ACLRoles, ACLActions, Administration)
Affects SuiteCRM before 7.15.2 and from 8.0.0 to before 8.10.2 when the V8 REST API is enabled and an authenticated user holds a valid OAuth2 token. Fixed in 7.15.2 and 8.10.2.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 7.15.2, 8.10.2
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. The V8 REST API must be enabled and the attacker needs a valid OAuth2 token for an authenticated user account
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 17/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Affected SuiteCRM customer relationship management software lets a low-privileged authenticated user, reached remotely through the V8 module API, create roles, change access levels, and alter global settings, gaining administrator-equivalent control over CRM data and behavior. Because the API exposes administrator-only modules to any authenticated OAuth2 user, the flaw requires only a login with low privileges and no user interaction.
Read the original description
SuiteCRM is an open-source, enterprise-ready Customer Relationship Management (CRM) software application. Prior to 7.15.2 and 8.10.2, the V8 module API exposes CRUD operations for administrator-only modules to any authenticated OAuth2 user. The affected flow begins at /Api/V8/module and uses ACLRoles, ACLActions, and Administration to carry attacker-controlled data or authorization state into the security-sensitive operation. A low-privileged user can create roles, change ACL levels, bind elevated roles, and alter global configuration to obtain administrator-equivalent control of CRM data and behavior. This issue is fixed in versions 7.15.2 and 8.10.2.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Unknown. No tracked technology or package matched
- Severity8.8/10CVSS 8.8
- No patch0/5No signal
What would change the score
- Would score about 67 if added to CISA KEV
- Would score about 62 if CISA's SSVC rates exploitation active
- Would score about 24 if CISA's SSVC rates it automatable
What to do
Check whether your setup matches what the bug needs.
The V8 REST API must be enabled and the attacker needs a valid OAuth2 token for an authenticated user accountUpgrade to a fixed version: 7.15.2, 8.10.2.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- SuiteCRM SuiteCRM
fixed in 7.15.2; From 8.0.0 · fixed in 8.10.2
Evidence 5
- Advisory
- Repository
- Repository
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-100363
Is CVE-2026-100363 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
An authenticated low-privileged user can create roles, change ACL access levels, bind elevated roles to their own account, and write global Administration configuration. This can lead to administrator-equivalent control of CRM data and behavior.Source: github.com
Which versions are affected by CVE-2026-100363?
SuiteCRM: before 7.15.2; from 8.0.0 before 8.10.2.Source: cve.now feed data
Am I affected, and how do I check?
SuiteCRM versions before 7.15.2, and versions from 8.0.0 up to but not including 8.10.2. The setup involves the V8 REST API being enabled and an authenticated user with a valid OAuth2 token. Check the installed SuiteCRM version and whether the V8 REST API is enabled in the installation.Source: github.com
How do I fix CVE-2026-100363?
Upgrade to 7.15.2 on the 7.x line or to 8.10.2 on the 8.x line. The advisory lists no workaround.Source: github.com