SuiteCRM: Mass Assignment in V8 API Allows Modification of Sensitive User Fields (user_hash, external_auth_only)
SuiteCRM 7.15.1 and earlier, and 8.10.1 and earlier, are affected through the V8 REST API write path. Fixed in 7.15.2 and 8.10.2.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 7.15.2, 8.10.2
- Who is exposed
- Specific setups only
Do first: Check whether your setup matches what the bug needs. SuiteCRM 7.15.1 and earlier, or 8.10.1 and earlier, are affected The V8 REST API write path (PATCH /Api/V8/module) only checks field existence and does not enforce api-visible:false and sensitive:true restrictions
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 15/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
SuiteCRM, an open-source customer relationship management application, has a mass assignment flaw in its V8 API that lets a logged-in user modify internal authentication fields such as password hashes and external-authentication flags, which can give them unauthorized account access. The flaw can be reached remotely over the network by any user with a low-privilege account, and no user interaction is needed.
Read the original description
SuiteCRM is an open-source, enterprise-ready Customer Relationship Management (CRM) software application. Prior to 7.15.2 and 8.10.2, the V8 write path checks that a field exists but does not enforce api-visible or sensitive metadata that hides the same field on reads. The affected flow begins at PATCH /Api/V8/module and uses user_hash, external_auth_only, api-visible: false, and sensitive: true to carry attacker-controlled data or authorization state into the security-sensitive operation. An authenticated user can mass-assign internal authentication fields, modify password hashes or external-authentication flags, and persist unauthorized account access. This issue is fixed in versions 7.15.2 and 8.10.2.
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure8/25Specific setups only, reachable over the network
- Reach?/20Unknown. No tracked technology or package matched
- Severity7.1/10CVSS 7.1
- No patch0/5No signal
What would change the score
- Would score about 65 if added to CISA KEV
- Would score about 60 if CISA's SSVC rates exploitation active
- Would score about 22 if CISA's SSVC rates it automatable
What to do
Check whether your setup matches what the bug needs.
SuiteCRM 7.15.1 and earlier, or 8.10.1 and earlier, are affected The V8 REST API write path (PATCH /Api/V8/module) only checks field existence and does not enforce api-visible:false and sensitive:true restrictionsUpgrade to a fixed version: 7.15.2, 8.10.2.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- SuiteCRM SuiteCRM
fixed in 7.15.2; From 8.0.0 · fixed in 8.10.2
Evidence 5
- Advisory
- Repository
- Repository
- Repository
- Repository
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-100361
Is CVE-2026-100361 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The V8 REST API write path checks only that a field exists, not whether it is restricted. An authenticated user can therefore change hidden sensitive fields such as user_hash and external_auth_only, which may let them keep unauthorized account access.Source: github.com
Which versions are affected by CVE-2026-100361?
SuiteCRM: before 7.15.2; from 8.0.0 before 8.10.2.Source: cve.now feed data
Am I affected, and how do I check?
SuiteCRM 7.15.1 and earlier, and 8.10.1 and earlier, are affected. Check the installed version in the SuiteCRM admin area, and note whether the V8 REST API (PATCH /Api/V8/module) is in use.Source: github.com
How do I fix CVE-2026-100361?
Upgrade SuiteCRM 7 installs to 7.15.2 or later, and SuiteCRM 8 installs to 8.10.2 or later.Source: github.com