Skip to main content
← Vulnerabilities

Apache ZooKeeper: Denial of service through unbounded memory allocation in multiRead request handling

Affects Apache ZooKeeper 3.8.0 through 3.8.7 and 3.9.0 through 3.9.6. The fix is upgrading to 3.9.7.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.1HighCNA
Exploited
No known exploitation
Fix
Fixed in 3.9.7
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Apache ZooKeeper versions from 3.7.0 through 3.9.6 are affected The multiRead request handler is reached by the request

25Pcve.now Index 25 of 100 · methodology v3 · provisional
  • Exploitation0/40No signal
  • Exposure8/25Specific setups only, reachable over the network
  • Reach10/20Affects Maven packages
  • Severity7.1/10CVSS 7.1
  • No patch0/5No signal

What would change the score

  • Would score about 75 if added to CISA KEV
  • Would score about 70 if CISA's SSVC rates exploitation active
  • Would score about 32 if CISA's SSVC rates it automatable

CVE-2026-100302 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects Apache ZooKeeper; fixed in 3.9.7.

Published
Last modified
Published
Not listed in CISA KEV
25/100 · provisional
Specific setups only
Fix
Fixed in 3.9.7
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Allocation of Resources Without Limits or Throttling in the multiRead request handler of Apache ZooKeeper allows a remote attacker to crash the server (denial of service) with a single small request. The multiRead handler places no limit on the number of bundled read operations or on the cumulative size of the response it builds in memory. Because each operation's result is fully materialized and retained before serialization, a request that is small on the wire — within the jute.maxbuffer limit — but that references a large znode many times can force the server to allocate far more heap than the request size implies, exhausting the JVM heap and terminating the server with an OutOfMemoryError. Neither jute.maxbuffer nor largeRequestMaxBytes prevents this, as both bound only the inbound request, not the response. This issue affects Apache ZooKeeper from 3.7.0 through 3.9.6. Users are recommended to upgrade to version 3.9.7, which enforces configurable limits on the multiRead operation count and cumulative response size.

Impact

  • Widely used

    175 packages depend on org.apache.zookeeper:zookeeper.Source: deps.dev

What to do

  • Check whether your setup matches what the bug needs.

    Apache ZooKeeper versions from 3.7.0 through 3.9.6 are affected The multiRead request handler is reached by the request
  • Upgrade to a fixed version: 3.9.7.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • org.apache.zookeeper:zookeeperMaven

    From 3.9.0 · through 3.9.6; From 3.8.0 · through 3.8.7

Evidence 2

  1. Advisory
  2. Link

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-100302

Is CVE-2026-100302 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

A single small multiRead request makes the server allocate excessive heap memory. This exhausts the JVM heap and crashes the server with an OutOfMemoryError. The multiRead handler places no limit on the number of bundled read operations.Source: openwall.com

Which versions are affected by CVE-2026-100302?

org.apache.zookeeper:zookeeper (Maven): from 3.9.0 through 3.9.6; from 3.8.0 through 3.8.7.Source: cve.now feed data

Am I affected, and how do I check?

The ranges list Apache ZooKeeper 3.8.0 through 3.8.7 and 3.9.0 through 3.9.6. The advisory text also says 3.7.0 through 3.9.6. To check a installation, look at the ZooKeeper version it runs.Source: openwall.com

How do I fix CVE-2026-100302?

Upgrade to Apache ZooKeeper 3.9.7, which the advisory recommends. The checked facts do not list a fixed release on the 3.8 line.Source: openwall.com