Apache ZooKeeper: Unauthenticated persistent denial of service via unvalidated quota-node data and paths crashing the transaction-apply…
Affects Apache ZooKeeper 3.8.0 through 3.8.7 and 3.9.0 through 3.9.6, where an attacker must be able to write under the /zookeeper/quota subtree. Fixed in 3.8.8 and 3.9.7.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 3.8.8, 3.9.7
- Who is exposed
- Default setups
Do first: Check every install: default setups are affected.
- Exploitation0/40No signal
- Exposure25/25Default setups, CISA rates it automatable
- Reach10/20Affects Maven packages
- Severity8.7/10CVSS 8.7
- No patch0/5No signal
What would change the score
- Would score about 84 if added to CISA KEV
- Would score about 79 if CISA's SSVC rates exploitation active
CVE-2026-100300 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects Apache ZooKeeper; fixed in 3.8.8 and 3.9.7.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 44/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Default setups
- Fix
- Fixed in 3.8.8, 3.9.7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: yes
- Technical impact: partial
Summary
Apache ZooKeeper's quota subsystem can be crashed by an attacker who can write under the /zookeeper/quota subtree, which on default deployments is world-writable. The attack can be carried out remotely, without logging in, and it can leave the on-disk data directory permanently unbootable, so the server cannot recover without intervention.
Read the original description
Improper handling of exceptional conditions in the quota subsystem of Apache ZooKeeper allows an attacker able to write under the /zookeeper/quota subtree — unauthenticated on default deployments, where that subtree is world-writable — to crash the server's critical request-processing thread and render the on-disk data directory permanently unbootable. This issue affects Apache ZooKeeper up to and including 3.9.6. Users are recommended to upgrade to version 3.8.8 or 3.9.7, which fixes the issue.
Impact
- Widely used
175 packages depend on org.apache.zookeeper:zookeeper.Source: deps.dev
What to do
Check every install: default setups are affected.
Upgrade to a fixed version: 3.8.8, 3.9.7.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: yes · Technical impact: partial
- Record last updated
Affected versions
- org.apache.zookeeper:zookeeperMaven
From 3.9.0 · through 3.9.6; From 3.8.0 · through 3.8.7
Evidence 2
- Advisory
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-100300
Is CVE-2026-100300 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
A crafted write under the /zookeeper/quota subtree carries quota-node data and paths that ZooKeeper does not validate. Applying that transaction crashes the server's request-processing thread, and the on-disk data directory can then no longer be started.Source: openwall.com
Which versions are affected by CVE-2026-100300?
org.apache.zookeeper:zookeeper (Maven): from 3.9.0 through 3.9.6; from 3.8.0 through 3.8.7.Source: cve.now feed data
Am I affected, and how do I check?
Apache ZooKeeper 3.8.0 through 3.8.7 and 3.9.0 through 3.9.6 are listed as affected. The check is the installed ZooKeeper version, and the exposure additionally depends on whether untrusted clients can write under /zookeeper/quota.Source: openwall.com
How do I fix CVE-2026-100300?
Upgrade to Apache ZooKeeper 3.8.8 or 3.9.7, which fix the issue. No workaround is listed in the advisory facts.Source: openwall.com