Skip to main content
← Vulnerabilities

Integer overflow vulnerability in XML parsing functionality of Qt5Compat impacts Qt

Affects Qt 6.0 through 6.8.9, 6.9.0 through 6.11.2, and 6.12.0 when an application parses specially crafted XML with the Qt5Compat XML parser. CVSS rates it Low (1.9). Fixed in Qt 6.8.10, 6.11.3, and 6.12.1.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

1.9LowCNA
Exploited
No known exploitation
Fix
Fixed in Qt 6.8.10, Qt 6.11.3, Qt 6.12.1
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. Affected Qt versions: from Qt 6.0 to Qt 6.8.9, from Qt 6.9.0 to Qt 6.11.2, and Qt 6.12.0 The application must process a specially crafted XML document in the Qt5Compat XML parser

Published
Last modified
Published
Not listed in CISA KEV
7/100 · provisional
Specific setups only
Fix
Fixed in Qt 6.8.10, Qt 6.11.3, Qt 6.12.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

The Qt framework's XML parsing component, which is part of the Qt5Compat module, contains an integer overflow flaw that can be triggered when processing XML input. Successful exploitation could potentially lead to unexpected application behavior, such as crashes or memory-related errors.

Read the original description

An integer overflow vulnerability in the Qt XML parsing (Qt5Compat / QXmlSimpleReader) functionality of Qt.

What to do

  • Check whether your setup matches what the bug needs.

    Affected Qt versions: from Qt 6.0 to Qt 6.8.9, from Qt 6.9.0 to Qt 6.11.2, and Qt 6.12.0 The application must process a specially crafted XML document in the Qt5Compat XML parser
  • Upgrade to a fixed version: Qt 6.8.10, Qt 6.11.3, Qt 6.12.1.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • qt qt

    From 6.0.0 · through 6.8.9; From 6.9.0 · through 6.11.2

Evidence 5

  1. Advisory
  2. Patch
  3. Patch
  4. Patch
  5. Patch

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2026-100140

What does this mean?

An integer overflow in the Qt5Compat XML parser can corrupt internal memory handling when a specially crafted XML document is processed. In the worst case this can crash the application or corrupt data.Source: wiki.qt.io

Am I affected, and how do I check?

Qt 6.0 to 6.8.9, 6.9.0 to 6.11.2, and 6.12.0 are listed as affected. The issue needs an application that processes XML through the Qt5Compat XML parser, so check your Qt version and whether that module is in use.Source: wiki.qt.io

What should I do about it?

Upgrade to Qt 6.8.10, Qt 6.11.3, or Qt 6.12.1, matching your release line. No workaround is listed in the checked facts.Source: wiki.qt.io

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data