- Exploited
- No known exploitation
- Fix
- Fixed in 5.10.274, 5.15.225, 6.1.192, 6.6.162, 6.12.116, and 2 more
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 5.10.274, 5.15.225, 6.1.192, 6.6.162, 6.12.116, or one of 2 more.
- Last modified
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 20/100 · provisional
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Linux kernel's Xen block backend (xen-blkback) is affected. Reading I/O statistics through sysfs while a frontend device is being torn down can cause a use-after-free or NULL pointer dereference, which may crash the system.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
Read the original description
In the Linux kernel, the following vulnerability has been resolved:
xen-blkback: Avoid UAF when reading I/O statistics
Reading I/O statistics via sysfs concurrently with tearing down a frontend device might result in UAF or a NULL dereference, as the reading of the statistics data is not synchronized with freeing the data.
Use a rwlock for synchronizing.
This is XSA-528 / CVE-2026-100082
cve.now Index
- Exploitation?/40Unknown. No CISA SSVC exploitation rating yet
- Exposure?/25Unknown. No advisory context yet
- Reach20/20Affects Linux kernel (software on nearly every server, desktop or phone)
- Severity?/10Unknown. No CVSS score or vendor rating
- No patch0/5No signal
What would change the score
- Would score about 75 if added to CISA KEV
- Would score about 70 if CISA's SSVC rates exploitation active
- Would score about 42 if advisories confirm default setups are exposed
What to do
Upgrade to a fixed version: 5.10.274, 5.15.225, 6.1.192, 6.6.162, 6.12.116, or one of 2 more.
Timeline
- CVE published
- First seen by cve.now
- Record last updated
Affected versions
- Linux Linux
fixed in 5.10.274; fixed in 5.15.225; fixed in 6.1.192; fixed in 6.6.162; fixed in 6.12.116; fixed in 6.18.62; fixed in 7.3.3
- Linux Linux
Version range not reported
Evidence 9
- Link
- Link
- Link
- Link
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2026-100082
Is CVE-2026-100082 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2026-100082?
Linux: before 5.10.274; before 5.15.225; before 6.1.192; before 6.6.162; before 6.12.116; before 6.18.62; before 7.3.3.Source: cve.now feed data
How do I fix CVE-2026-100082?
Upgrade to a fixed version: 5.10.274, 5.15.225, 6.1.192, 6.6.162, 6.12.116, or one of 2 more.Source: cve.now feed data