Skip to main content
← All vulnerabilities
CVE-2026-0322

PAN-OS: Authenticated Remote Code Execution (RCE) in the Management Interface

Affects PAN-OS on PA-Series and VM-Series firewalls and on Panorama (virtual and M-Series). Fixed in 12.2.4, 12.1.10-h2, 11.2.16, 11.1.16-h3 and 10.2.18-h12.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 12.2.4, 12.1.10-h2, 11.2.16, 11.1.16-h3, 10.2.18-h12
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: active
  • Automatable: no
  • Technical impact: total

Summary

PAN-OS, the operating system for Palo Alto Networks PA-Series and VM-Series firewalls and for Panorama (virtual and M-Series), is affected by this vulnerability. An attacker who has valid login credentials and network access to the management interface could run arbitrary code with root privileges on the device.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

A remote code execution (RCE) vulnerability in the management interface of Palo Alto Networks PAN-OS® software enables an authenticated attacker with network access to execute arbitrary code with root privileges on the firewall. The security risk posed by this issue is minimized by restricting access to the management interface to only trusted internal IP addresses according to our recommended  best practice deployment guidelines https://live.paloaltonetworks.com/t5/community-blogs/tips-amp-tricks-how-to-secure-the-management-access-of-your-palo/ba-p/464431 . This issue is applicable to PAN-OS software on PA-Series and VM-Series firewalls and on Panorama (virtual and M-Series). Cloud NGFW and Prisma® Access are not impacted by this vulnerability.

Timeline

  1. CISA SSVC assessment

    Exploitation: active · Automatable: no · Technical impact: total

  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CVE published
  4. Record last updated
  5. CISA remediation deadline

    Due date for US federal agencies to patch

Affected versions

  • Palo Alto Networks Cloud NGFW

    Version range not reported

  • Palo Alto Networks PAN-OS

    From 12.2.0 · fixed in 12.2.4; From 12.1.0 · fixed in 12.1.10-h2; From 11.2.0 · fixed in 11.2.16; From 11.1.0 · fixed in 11.1.16-h3; From 10.2.0 · fixed in 10.2.18-h12

  • Palo Alto Networks Prisma Access

    Version range not reported

References 1

security.paloaltonetworks.com

FAQ

Questions about CVE-2026-0322

What does this mean?

An attacker who is already authenticated can run arbitrary code with root privileges on the firewall through the management interface. The flaw is in PAN-OS management access, not in the traffic the firewall inspects.Source: security.paloaltonetworks.com

Am I affected, and how do I check?

The issue applies to PAN-OS on PA-Series and VM-Series firewalls and on Panorama (virtual and M-Series). Affected PAN-OS ranges begin at 10.2.0, 11.1.0, 11.2.0, 12.1.0 and 12.2.0 and run up to, but not including, the fixed release for each branch. To check, compare the PAN-OS version shown in the device dashboard or by running the show system info command against those ranges.Source: security.paloaltonetworks.com

What should I do about it?

Upgrade to 12.2.4 or later on the 12.2 branch. On other branches, upgrade to the first fixed release listed for that branch: 12.1.10-h2, 11.2.16, 11.1.16-h3 or 10.2.18-h12.Source: security.paloaltonetworks.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-10-14, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data