vtenext 25.02 before 25.02.1 Unverified Password Change via hub/rpwd.php
Affects vtenext 25.02 before 25.02.1, where unauthenticated users can change any account's password. Fixed in 25.02.1.
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 25.02.1
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 25.02.1.
- Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
- Exposure17/25No login or user action needed, reachable over the network without a login · Data gap: Advisories don't say whether default setups are affected
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity9.3/10CVSS 9.3
- No patch0/5No signal
What would change the score
- Would score about 71 if added to CISA KEV
- Would score about 66 if CISA's SSVC rates exploitation active
- Would score about 31 if advisories confirm default setups are exposed
CVE-2025-71457 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.3 (critical) and affects vtenext; fixed in 25.02.1.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 26/100 · provisional
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Unclear
- Fix
- Fixed in 25.02.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The vtenext 25.02 software before 25.02.1 can be attacked remotely, without logging in, through its hub/rpwd.php password recovery page. An attacker who knows a valid username can change that account's password without any token check, which can lead to taking over the account, including administrator accounts that lack two-factor authentication.
Read the original description
vtenext 25.02 before 25.02.1 contains an authentication bypass vulnerability that allows unauthenticated attackers to change any account password via hub/rpwd.php without token verification. Attackers knowing a valid user_name can send action=change_password to RecoverPwd::displayChangePwd() and log in as administrators lacking two-factor authentication.
What to do
Upgrade to a fixed version: 25.02.1.
Timeline
- CVE published
- First seen by cve.now
- Posted on X by cve.now
Affected versions
- vtenext vtenext
From 25.02 · fixed in 25.02.1
Evidence 4
- Exploit
- Link
- Link
- Link
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2025-71457
Is CVE-2025-71457 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
What does this mean?
The hub/rpwd.php endpoint lets an unauthenticated visitor who knows a valid user name change that account's password through action=change_password. The attacker can then log in, including as administrators who lack two-factor authentication.Source: vulncheck.com, 0xbro.red
Which versions are affected by CVE-2025-71457?
vtenext: from 25.02 before 25.02.1.Source: cve.now feed data
Am I affected, and how do I check?
Versions from 25.02 up to but not including 25.02.1 are in scope. Check the installed vtenext version against that range. The issue concerns accounts that can be reached by user name, and administrator accounts without two-factor authentication carry the most serious consequence.Source: vulncheck.com, 0xbro.red
How do I fix CVE-2025-71457?
Upgrade vtenext to 25.02.1 or later. The vendor released 25.02.1 with a silent patch for this password reset flaw, and no workaround is listed in the facts.Source: vulncheck.com, 0xbro.red