Skip to main content
← All vulnerabilities
CVE-2025-68613GHSA-V98V-FF95-F3CP

n8n Vulnerable to Remote Code Execution via Expression Injection

n8n versions 0.211.0 through 1.120.4 and 1.121.0 through 1.121.1 are affected. The fix is in n8n 1.122.0, and the CVSS score is 10 (critical). The vendor has not given its own severity rating.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 1.120.4, 1.121.1
None on Exploit-DB, Metasploit or GitHub

Summary

n8n, an open source workflow automation platform, is affected by this vulnerability. An authenticated user could exploit it to run arbitrary code with the privileges of the n8n process, potentially gaining full control of the instance, including access to sensitive data and the ability to modify workflows.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

n8n is an open source workflow automation platform. Versions starting with 0.211.0 and prior to 1.120.4, 1.121.1, and 1.122.0 contain a critical Remote Code Execution (RCE) vulnerability in their workflow expression evaluation system. Under certain conditions, expressions supplied by authenticated users during workflow configuration may be evaluated in an execution context that is not sufficiently isolated from the underlying runtime. An authenticated attacker could abuse this behavior to execute arbitrary code with the privileges of the n8n process. Successful exploitation may lead to full compromise of the affected instance, including unauthorized access to sensitive data, modification of workflows, and execution of system-level operations. This issue has been fixed in versions 1.120.4, 1.121.1, and 1.122.0. Users are strongly advised to upgrade to a patched version, which introduces additional safeguards to restrict expression evaluation. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only; and/or deploy n8n in a hardened environment with restricted operating system privileges and network access to reduce the impact of potential exploitation. These workarounds do not fully eliminate the risk and should only be used as short-term measures.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. Record last updated
  4. CISA remediation deadline

    Due date for US federal agencies to patch

  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n8n-io n8n

    From 0.211.0 · fixed in 1.120.4

  • n8nnpm

    From 0.211.0 · fixed in 1.120.4

  • n8nnpm

    From 1.121.0 · fixed in 1.121.1

References 4

GitHub · n8n-io/n8n

FAQ

Questions about CVE-2025-68613

What does this mean?

Under certain conditions, expressions supplied by logged-in users while configuring a workflow may be evaluated in an execution context that is not sufficiently isolated from the n8n runtime. This can let arbitrary code run with the privileges of the n8n process.Source: github.com

Am I affected, and how do I check?

The affected ranges are n8n 0.211.0 up to 1.120.4 and n8n 1.121.0 up to 1.121.1. To check, compare the installed n8n version against these ranges. The issue concerns authenticated users who can create or edit workflows.Source: github.com

What should I do about it?

Upgrade to n8n 1.122.0, which the advisory says fixes the issue. Until the upgrade is done, limit workflow creation and editing permissions to fully trusted users only.Source: github.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-03-11, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data