GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature
Affects GeoServer 2.26.0 through 2.26.1 and 2.25.5 and earlier via the WMS GetMap feature. Fixed in 2.25.6, 2.26.3, and 2.27.0.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 2.26.2, 2.25.6
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
GeoServer, an open source server for sharing and editing geospatial data, is affected by an unauthenticated XML External Entity (XXE) flaw in its WMS GetMap operation. An attacker who can reach the server without logging in could abuse this flaw to make the server process malicious XML input that reads or interacts with unintended external resources.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- geoserver geoserver
From 2.26.0 · fixed in 2.26.2; fixed in 2.25.6
- org.geoserver.web:gs-web-appMaven
From 2.26.0 · fixed in 2.26.2
- org.geoserver:gs-wmsMaven
From 2.26.0 · fixed in 2.26.2
- org.geoserver.web:gs-web-appMaven
fixed in 2.25.6
- org.geoserver:gs-wmsMaven
fixed in 2.25.6
References 2
GitHub · geoserver/geoserver
osgeo-org.atlassian.net
Questions about CVE-2025-58360
What does this mean?
The WMS GetMap feature processes XML in a way that lets an unauthenticated attacker make GeoServer read arbitrary files from the server's file system.Source: github.com
Am I affected, and how do I check?
Affected GeoServer versions are 2.26.0 through 2.26.1, and 2.25.5 and earlier. Compare the installed GeoServer version against these ranges to see whether this applies to your deployment.Source: github.com
What should I do about it?
Update to GeoServer 2.25.6, GeoServer 2.26.3, or GeoServer 2.27.0. No workaround is listed in the facts.Source: github.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-12-11, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data