Skip to main content
← All vulnerabilities
CVE-2025-58034

An Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability [CWE-78] vulnerability in Fortin

Affects FortiWeb 7.0.0 through 8.0.1 across several release branches, with CVSS 6.7 (medium) and no vendor rating given. Fixed in 8.0.2.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 8.0.2
None on Exploit-DB, Metasploit or GitHub

Summary

Fortinet FortiWeb web application firewall software (versions 7.0 through 8.0) is affected by this vulnerability. An authenticated attacker could exploit it to run unauthorized commands on the underlying operating system through specially crafted HTTP requests or CLI commands.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

An Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability [CWE-78] vulnerability in Fortinet FortiWeb 8.0.0 through 8.0.1, FortiWeb 7.6.0 through 7.6.5, FortiWeb 7.4.0 through 7.4.10, FortiWeb 7.2.0 through 7.2.11, FortiWeb 7.0.0 through 7.0.11 may allow an authenticated attacker to execute unauthorized code on the underlying system via crafted HTTP requests or CLI commands.

Timeline

  1. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  2. CVE published
  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Fortinet FortiWeb

    From 7.6.0 · through 7.6.4; From 7.4.0 · through 7.4.8; From 7.2.0 · through 7.2.11; From 7.0.2 · through 7.0.11

References 1

fortiguard.fortinet.com

FAQ

Questions about CVE-2025-58034

What does this mean?

An authenticated attacker can run unauthorized code on the underlying system through crafted HTTP requests or CLI commands. This is an OS command injection flaw (CWE-78).Source: fortiguard.fortinet.com

Am I affected, and how do I check?

The advisory lists FortiWeb 8.0.0 through 8.0.1, 7.6.0 through 7.6.5, 7.4.0 through 7.4.10, 7.2.0 through 7.2.11, and 7.0.0 through 7.0.11. Compare the FortiWeb version shown in the admin interface or the CLI against these ranges.Source: fortiguard.fortinet.com

What should I do about it?

Upgrade to FortiWeb 8.0.2 or above, as the advisory states.Source: fortiguard.fortinet.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-11-18, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data