Skip to main content
← Vulnerabilities

Reflected Cross-Site Scripting via Authentication Endpoint in Multiple WSO2 Products Allows Browser Redirection and UI Modification

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

6.1MediumCNA
Exploited
No known exploitation
Fix
Fixed in 4.5.0.11, 3.2.0.430, 3.2.1.50, 4.1.0.212, 4.2.0.150, and 9 more
Who is exposed
Not reported

Do first: Upgrade to a fixed version: 4.5.0.11, 3.2.0.430, 3.2.1.50, 4.1.0.212, 4.2.0.150, or one of 9 more.

13Pcve.now Index 13 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure7/25Reachable over the network without a login · Data gap: No advisory context yet
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity6.1/10CVSS 6.1
  • No patch0/5No signal

What would change the score

  • Would score about 68 if added to CISA KEV
  • Would score about 63 if CISA's SSVC rates exploitation active
  • Would score about 28 if advisories confirm default setups are exposed

CVE-2025-5769 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.1 (medium) and affects WSO2 API Control Plane, WSO2 API Manager and WSO2 Identity Server; fixed in 4.5.0.11, 3.2.0.430, 3.2.1.50 and 11 more.

Published
Last modified
Published
Not listed in CISA KEV
0.17% · 6th percentile
13/100 · provisional
Fix
Fixed in 4.5.0.11, 3.2.0.430, 3.2.1.50, 4.1.0.212, 4.2.0.150, and 9 more
None on Exploit-DB, Metasploit or GitHub

Summary

Multiple WSO2 products that provide an authentication login page are affected by this flaw. An attacker could exploit it to redirect users to malicious websites, alter the content shown on the page, or steal data from the browser, though session cookies remain protected from hijacking.

Read the original description

The authentication endpoint does not properly encode user-supplied input before rendering it within the web page. This lack of output encoding allows an attacker to inject malicious JavaScript payloads into the authentication flow, which are then executed by the victim's browser. By exploiting this vulnerability, an attacker can redirect the user's browser to a malicious website, modify the content of the web page displayed to the user, or exfiltrate information from the browser. However, due to the implementation of the httpOnly flag on session-related sensitive cookies, session hijacking and similar attacks are not possible.

What to do

  • Upgrade to a fixed version: 4.5.0.11, 3.2.0.430, 3.2.1.50, 4.1.0.212, 4.2.0.150, or one of 9 more.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • WSO2 WSO2 API Control Plane

    From 4.5.0 · fixed in 4.5.0.11

  • WSO2 WSO2 API Manager

    From 3.2.0 · fixed in 3.2.0.430; From 3.2.1 · fixed in 3.2.1.50; From 4.1.0 · fixed in 4.1.0.212; From 4.2.0 · fixed in 4.2.0.150; From 4.3.0 · fixed in 4.3.0.63; From 4.4.0 · fixed in 4.4.0.26; From 4.5.0 · fixed in 4.5.0.10

  • WSO2 WSO2 Identity Server

    From 5.10.0 · fixed in 5.10.0.359; From 5.11.0 · fixed in 5.11.0.404; From 6.0.0 · fixed in 6.0.0.237; From 6.1.0 · fixed in 6.1.0.234; From 7.0.0 · fixed in 7.0.0.107; From 7.1.0 · fixed in 7.1.0.12

Evidence 1

  1. Advisory

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2025-5769

Is CVE-2025-5769 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

Which versions are affected by CVE-2025-5769?

WSO2 API Control Plane: from 4.5.0 before 4.5.0.11. WSO2 API Manager: from 3.2.0 before 3.2.0.430; from 3.2.1 before 3.2.1.50; from 4.1.0 before 4.1.0.212; from 4.2.0 before 4.2.0.150; from 4.3.0 before 4.3.0.63; from 4.4.0 before 4.4.0.26; from 4.5.0 before 4.5.0.10. WSO2 Identity Server: from 5.10.0 before 5.10.0.359; from 5.11.0 before 5.11.0.404; from 6.0.0 before 6.0.0.237; from 6.1.0 before 6.1.0.234; from 7.0.0 before 7.0.0.107; from 7.1.0 before 7.1.0.12.Source: cve.now feed data

How do I fix CVE-2025-5769?

Upgrade to a fixed version: 4.5.0.11, 3.2.0.430, 3.2.1.50, 4.1.0.212, 4.2.0.150, or one of 9 more.Source: cve.now feed data