A pre-authentication remote code execution vulnerability exists in React Server Components versions 19.0.0, 19.1.0, 19.1.1, and 19.2.0 inclu
Affects react-server-dom-webpack, -parcel, and -turbopack at 19.0.0, 19.1.0, 19.1.1, and 19.2.0 in apps using a supporting framework or bundler. Fixed in 19.0.1, 19.1.2, and 19.2.1.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 19.0.1, 19.1.2, 19.2.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 on Exploit-DB
- Exploitation: active
- Automatable: yes
- Technical impact: total
Summary
React Server Components, including the react-server-dom-parcel, react-server-dom-turbopack, and react-server-dom-webpack packages, is affected. An attacker who can send HTTP requests to Server Function endpoints could run arbitrary code on the server without logging in.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
A pre-authentication remote code execution vulnerability exists in React Server Components versions 19.0.0, 19.1.0, 19.1.1, and 19.2.0 including the following packages: react-server-dom-parcel, react-server-dom-turbopack, and react-server-dom-webpack. The vulnerable code unsafely deserializes payloads from HTTP requests to Server Function endpoints.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Public exploit on Exploit-DB
EDB-52506
- CISA SSVC assessment
Exploitation: active · Automatable: yes · Technical impact: total
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Meta react-server-dom-webpack
From 19.0.0 · through 19.0.0; From 19.1.0 · through 19.1.1; From 19.2.0 · through 19.2.0
- Meta react-server-dom-turbopack
From 19.0.0 · through 19.0.0; From 19.1.0 · through 19.1.1; From 19.2.0 · through 19.2.0
- Meta react-server-dom-parcel
From 19.0.0 · through 19.0.0; From 19.1.0 · through 19.1.1; From 19.2.0 · through 19.2.0
- react-server-dom-webpacknpm
From 19.0.0 · fixed in 19.0.1
- react-server-dom-webpacknpm
From 19.1.0 · fixed in 19.1.2
- react-server-dom-webpacknpm
From 19.2.0 · fixed in 19.2.1
- react-server-dom-turbopacknpm
From 19.0.0 · fixed in 19.0.1
- react-server-dom-turbopacknpm
From 19.1.0 · fixed in 19.1.2
- react-server-dom-turbopacknpm
From 19.2.0 · fixed in 19.2.1
- react-server-dom-parcelnpm
From 19.0.0 · fixed in 19.0.1
- react-server-dom-parcelnpm
From 19.1.0 · fixed in 19.1.2
- react-server-dom-parcelnpm
From 19.2.0 · fixed in 19.2.1
References 3
Questions about CVE-2025-55182
What does this mean?
The flaw lets an unauthenticated attacker run code on the server, so no login is needed for the attack to reach the server.Source: facebook.com, react.dev
Am I affected, and how do I check?
Versions 19.0.0, 19.1.0, 19.1.1, and 19.2.0 of react-server-dom-webpack, react-server-dom-parcel, or react-server-dom-turbopack are affected, but only in apps that use a framework, bundler, or bundler plugin supporting React Server Components. Check the installed versions of these packages in the project's dependency list.Source: facebook.com, react.dev
What should I do about it?
Upgrade to the fixed release for your line: 19.0.1, 19.1.2, or 19.2.1.Source: facebook.com, react.dev
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-12-05, which means it has evidence of attacks. Public exploit code exists (Exploit-DB).Source: cisa.gov, cve.now feed data