Skip to main content
← All vulnerabilities
CVE-2025-54313GHSA-F29H-PXVX-F335

eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise.

Only affects eslint-config-prettier 8.10.1, 9.1.1, 10.1.6 and 10.1.7 on Windows, where installing the package runs malicious code. The fix is to roll back to 10.1.5 or earlier.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 8.10.2, 9.1.2, 10.1.8, 4.2.4, 0.11.10, and 3 more
None on Exploit-DB, Metasploit or GitHub

Summary

The eslint-config-prettier package, a commonly used configuration add-on for the ESLint code linter, has been compromised with malicious code. Installing the affected releases runs a script that launches malware on Windows systems.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

eslint-config-prettier 8.10.1, 9.1.1, 10.1.6, and 10.1.7 has embedded malicious code for a supply chain compromise. Installing an affected package executes an install.js file that launches the node-gyp.dll malware on Windows.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated

Affected versions

  • prettier eslint-config-prettier

    8.10.1, 9.1.1, 10.1.6, 10.1.7

  • eslint-config-prettiernpm

    From 8.10.1 · fixed in 8.10.2

  • eslint-config-prettiernpm

    From 9.1.1 · fixed in 9.1.2

  • eslint-config-prettiernpm

    From 10.1.6 · fixed in 10.1.8

  • eslint-plugin-prettiernpm

    From 4.2.2 · fixed in 4.2.4

  • synckitnpm

    From 0.11.9 · fixed in 0.11.10

  • @pkgr/corenpm

    From 0.2.8 · fixed in 0.2.9

  • napi-postinstallnpm

    From 0.3.1 · fixed in 0.3.2

  • got-fetchnpm

    From 5.1.11 · fixed in 6.0.0

References 7

socket.dev

bleepingcomputer.com

GitHub · prettier/eslint-config-prettier

npmjs.com

stepsecurity.io

news.ycombinator.com

FAQ

Questions about CVE-2025-54313

What does this mean?

Installing the package runs a postinstall script that launches a bundled malicious DLL (node-gyp.dll) through rundll32 on Windows. This could potentially allow remote code execution.Source: bleepingcomputer.com, github.com, socket.dev

Am I affected, and how do I check?

Versions 8.10.1, 9.1.1, 10.1.6 and 10.1.7 of eslint-config-prettier are affected, and the malicious code only runs on Windows (win32). To check an installed version, run npm ls eslint-config-prettier in the project directory.Source: bleepingcomputer.com, github.com, socket.dev

What should I do about it?

Roll back to eslint-config-prettier 10.1.5 or earlier, which the advisory names as the safe versions. The package records also list fixed releases of 8.10.2, 9.1.2 and 10.1.8 for the other release lines.Source: bleepingcomputer.com, github.com, socket.dev

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-01-22, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data