Skip to main content
← All vulnerabilities
CVE-2025-49113GHSA-8J8W-WWQC-X596

Roundcube Webmail before 1.5.10 and 1.6.x before 1.6.11 allows remote code execution by authenticated users because the _from parameter in a

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 1.5.10, 1.6.11
None on Exploit-DB, Metasploit or GitHub

Summary

Roundcube Webmail, an open-source email web application, is affected. An authenticated user could exploit this flaw to run arbitrary code on the server, potentially giving them control over the underlying system.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Roundcube Webmail before 1.5.10 and 1.6.x before 1.6.11 allows remote code execution by authenticated users because the _from parameter in a URL is not validated in program/actions/settings/upload.php, leading to PHP Object Deserialization.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. Record last updated
  4. CISA remediation deadline

    Due date for US federal agencies to patch

  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Roundcube Webmail

    fixed in 1.5.10; From 1.6.0 · fixed in 1.6.11

  • roundcube/roundcubemailPackagist

    fixed in 1.5.10

  • roundcube/roundcubemailPackagist

    From 1.6.0 · fixed in 1.6.11

References 10

roundcube.net

GitHub · roundcube/roundcubemail

fearsoff.org

vicarius.io

FAQ

Questions about CVE-2025-49113

What does this mean?

The _from parameter is passed into PHP object deserialization without proper checks, so a logged-in user can send crafted input that makes the server run code. The impact is remote code execution on the server.Source: roundcube.net

Am I affected, and how do I check?

Roundcube Webmail versions before 1.5.10 and 1.6.x before 1.6.11 are affected. To check a installation, look at the Roundcube version shown in the admin panel or the version file in the installed package.Source: roundcube.net

What should I do about it?

Upgrade to Roundcube 1.6.11 if you run the 1.6 series, or to 1.5.10 if you run the 1.5 series. Both fixed releases were published together as security updates.Source: roundcube.net

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-02-20, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data