Skip to main content
← All vulnerabilities
CVE-2025-43300

An out-of-bounds write issue was addressed with improved bounds checking.

Affects Apple iOS, iPadOS and macOS builds older than the fixed releases listed, and the advisory names iOS 18.6.2 and iPadOS 18.6.2 as the fix. No vendor rating is given.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 15.8.5, 16.7.12, 18.6.2, 17.7.10, 13.7.8, and 2 more
None on Exploit-DB, Metasploit or GitHub

Summary

Apple's iOS, iPadOS, and macOS are affected. Processing a maliciously crafted image file can corrupt memory, which may lead to unexpected behavior or crashes.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

An out-of-bounds write issue was addressed with improved bounds checking. This issue is fixed in iOS 15.8.5 and iPadOS 15.8.5, iOS 16.7.12 and iPadOS 16.7.12, iOS 18.6.2 and iPadOS 18.6.2, iPadOS 17.7.10, macOS Sequoia 15.6.1, macOS Sonoma 14.7.8, macOS Ventura 13.7.8. Processing a malicious image file may result in memory corruption. Apple is aware of a report that this issue may have been exploited in an extremely sophisticated attack against specific targeted individuals.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Apple iOS and iPadOS

    fixed in 15.8.5; fixed in 16.7.12; fixed in 18.6.2

  • Apple iPadOS

    fixed in 17.7.10

  • Apple macOS

    fixed in 13.7.8; fixed in 14.7.8; fixed in 15.6.1

References 7

support.apple.com

FAQ

Questions about CVE-2025-43300

What does this mean?

Processing a malicious image file can cause memory corruption, because the code writes data outside the memory bounds it should respect. Apple fixed it with improved bounds checking.Source: support.apple.com

Am I affected, and how do I check?

Affected are iOS and iPadOS before 15.8.5, 16.7.12 or 18.6.2, iPadOS before 17.7.10, and macOS before 13.7.8, 14.7.8 or 15.6.1. To check a device, look at the version under Settings, General, About on iPhone or iPad, or under About This Mac on a Mac.Source: support.apple.com

What should I do about it?

Update iOS and iPadOS to 18.6.2 or later, or install the fixed macOS release for the installed macOS branch (13.7.8, 14.7.8 or 15.6.1). The advisory names iOS 18.6.2 and iPadOS 18.6.2 as the fixed versions.Source: support.apple.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-08-21, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data