Skip to main content
← All vulnerabilities
CVE-2025-4008

Arbitrary Command Injection in Smartbedded MeteoBridge

Affects Smartbedded MeteoBridge version 6.1 and earlier where the template.cgi script is reachable through the unprotected public directory. Fixed in 6.2.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 6.2
None on Exploit-DB, Metasploit or GitHub

Summary

The Meteobridge weather station management software, which provides a web interface for administering weather data collection, is affected. A remote attacker without logging in could exploit an exposed web endpoint to run arbitrary commands with root-level privileges on the device.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

The Meteobridge web interface let meteobridge administrator manage their weather station data collection and administer their meteobridge system through a web application written in CGI shell scripts and C. This web interface exposes an endpoint that is vulnerable to command injection. Remote unauthenticated attackers can gain arbitrary command execution with elevated privileges ( root ) on affected devices.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Smartbedded MeteoBridge

    through 6.1

References 2

onekey.com

forum.meteohub.de

FAQ

Questions about CVE-2025-4008

What does this mean?

The template.cgi script in MeteoBridge lets a remote party run arbitrary commands on the device with root privileges, without logging in.Source: onekey.com

Am I affected, and how do I check?

MeteoBridge version 6.1 or earlier is affected when the template.cgi script is reachable through the public directory, which is itself unprotected. To check, compare the installed MeteoBridge version against 6.1 and see whether the affected CGI script is available in the public directory.Source: onekey.com

What should I do about it?

Upgrade MeteoBridge to version 6.2, the fixed version.Source: onekey.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-10-02, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data