Commvault Web Server unspecified vulnerability
Affects Commvault Web Server on Linux or Windows in 11.20.0-11.20.216, 11.28.0-11.28.140, 11.32.0-11.32.88 and 11.36.0-11.36.45 when reachable from the internet. Fixed in the matching 11.20.217, 11.28.141, 11.32.89 and 11.36.46 releases.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 11.36.46, 11.32.89, 11.28.141, 11.20.217
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: active
- Automatable: no
- Technical impact: total
Summary
Commvault Web Server on Windows and Linux systems contains an unspecified flaw that lets a remote attacker with valid credentials compromise the server by creating and running webshells.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Commvault Web Server has an unspecified vulnerability that can be exploited by a remote, authenticated attacker. According to the Commvault advisory: "Webservers can be compromised through bad actors creating and executing webshells." Fixed in version 11.36.46, 11.32.89, 11.28.141, and 11.20.217 for Windows and Linux platforms. This vulnerability was added to the CISA Known Exploited Vulnerabilities (KEV) Catalog on 2025-04-28.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA SSVC assessment
Exploitation: active · Automatable: no · Technical impact: total
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
Affected versions
- Commvault Web Server
From 11.36.0 · fixed in 11.36.46; From 11.32.0 · fixed in 11.32.89; From 11.28.0 · fixed in 11.28.141; From 11.20.0 · fixed in 11.20.217
References 6
documentation.commvault.com
cisa.gov
Questions about CVE-2025-3928
What does this mean?
The flaw lets a user who already holds authenticated credentials in the Commvault Software environment compromise the Commvault web server by creating and running webshells. Client computers are not affected.Source: documentation.commvault.com
Am I affected, and how do I check?
Affected versions are 11.20.0 to 11.20.216, 11.28.0 to 11.28.140, 11.32.0 to 11.32.88 and 11.36.0 to 11.36.45 on Linux or Windows. The issue only applies where the Commvault environment is accessible via the internet, so check the installed Web Server version and whether that environment is internet-reachable.Source: documentation.commvault.com
What should I do about it?
Upgrade to the fixed release for your branch: 11.20.217, 11.28.141, 11.32.89 or 11.36.46 or later.Source: documentation.commvault.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-04-28, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data