hisi_acc_vfio_pci: bugfix live migration function without VF device driver
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Specific setups only
- Fix
- Fixed in 6.6.94, 6.12.34, 6.15.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
In the Linux kernel, the following vulnerability has been resolved: hisi_acc_vfio_pci: bugfix live migration function without VF device driver If the VF device driver is not loaded in the Guest OS and we attempt to perform device data migration, the address of the migrated data will be NULL. The live migration recovery operation on the destination side will access a null address value, which will cause access errors. Therefore, live migration of VMs without added VF device drivers does not require device data migration. In addition, when the queue address data obtained by the destination is empty, device queue recovery processing will not be performed.
Timeline
- CVE published
- Record last updated
Affected versions
- Linux Linux
Version range not reported
- Linux Linux
5.18
- KernelLinux
From 5.18.0 · fixed in 6.6.94; From 6.7.0 · fixed in 6.12.34; From 6.13.0 · fixed in 6.15.3
References 5
Questions about CVE-2025-38283
What does this mean?
The hisi_acc_vfio_pci driver mishandles live migration when a virtual function's driver is not loaded in the guest OS and a device data migration is attempted. During recovery on the destination side, it reads a NULL address, which causes access errors.Source: git.kernel.org
Am I affected, and how do I check?
The checked facts list Linux kernel ranges from 5.18.0 to before 6.6.94, from 6.7.0 to before 6.12.34, and from 6.13.0 to before 6.15.3. To check a system, run uname -r to see the kernel version, and confirm whether the hisi_acc_vfio_pci module is in use.Source: git.kernel.org
What should I do about it?
Update the Linux kernel to a fixed release: 6.6.94, 6.12.34, 6.15.3, or later in the matching series. The facts do not describe a workaround.Source: git.kernel.org
Is it being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data