Skip to main content
← All vulnerabilities
CVE-2025-34291PYSEC-2025-78GHSA-577H-P2HH-V4MV

Langflow <= 1.6.9 CORS Misconfiguration to Token Hijack & RCE

Langflow versions up to and including 1.6.9 are affected, and the default deployment is vulnerable. The product data lists 1.7.0 as the fixed version.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 1.7.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: active
  • Automatable: no
  • Technical impact: total

Summary

Langflow, an open-source tool for building AI workflows, is affected in all versions up to and including 1.6.9. A malicious website visited by a logged-in user can steal their session tokens and use them to take over the account and run arbitrary code on the server, potentially gaining full control of the system.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Langflow versions up to and including 1.6.9 contain a chained vulnerability that enables account takeover and remote code execution. An overly permissive CORS configuration (allow_origins='*' with allow_credentials=True) combined with a refresh token cookie configured as SameSite=None allows a malicious webpage to perform cross-origin requests that include credentials and successfully call the refresh endpoint. An attacker-controlled origin can therefore obtain fresh access_token / refresh_token pairs for a victim session. Obtained tokens permit access to authenticated endpoints — including built-in code-execution functionality — allowing the attacker to execute arbitrary code and achieve full system compromise.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: active · Automatable: no · Technical impact: total

  3. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  4. CISA remediation deadline

    Due date for US federal agencies to patch

  5. Record last updated
  6. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Langflow Langflow

    through 1.6.9

  • langflowPyPI

    fixed in 1.7.0

References 3

obsidiansecurity.com

GitHub · langflow-ai/langflow

vulncheck.com

FAQ

Questions about CVE-2025-34291

What does this mean?

The CORS policy accepts any origin with credentials enabled, and the refresh token cookie is set to SameSite=None. Together these let a malicious site obtain fresh access and refresh token pairs for a victim's session, which can then be used on authenticated endpoints, including code execution.Source: vulncheck.com

Am I affected, and how do I check?

Langflow versions up to and including 1.6.9 are affected, and the default deployment is vulnerable. To check a setup, look at the installed Langflow version and at the CORS settings (allow_origins set to '*' with allow_credentials=True) and the refresh token cookie's SameSite attribute.Source: vulncheck.com

What should I do about it?

The product data lists 1.7.0 as the fixed version, so upgrade to Langflow 1.7.0 or later.Source: vulncheck.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-05-21, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data