Skip to main content
← All vulnerabilities
CVE-2025-32756

A stack-based buffer overflow vulnerability [CWE-121] vulnerability in Fortinet FortiCamera 2.1.0 through 2.1.3, FortiCamera 2.0 all version

Affects FortiCamera 2.1.0 through 2.1.3 reachable via crafted HTTP requests to the portal or administrative interface. Fixed in 2.1.4 or above.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 2.1.4
None on Exploit-DB, Metasploit or GitHub

Summary

A stack-based buffer overflow in Fortinet's FortiCamera, FortiMail, FortiNDR, FortiRecorder, and FortiVoice products allows a remote attacker without logging in to run arbitrary code or commands on the affected device by sending specially crafted HTTP requests with a malicious cookie.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

A stack-based buffer overflow vulnerability [CWE-121] vulnerability in Fortinet FortiCamera 2.1.0 through 2.1.3, FortiCamera 2.0 all versions, FortiCamera 1.1 all versions, FortiMail 7.6.0 through 7.6.2, FortiMail 7.4.0 through 7.4.4, FortiMail 7.2.0 through 7.2.7, FortiMail 7.0.0 through 7.0.8, FortiNDR 7.6.0, FortiNDR 7.4.0 through 7.4.7, FortiNDR 7.2.0 through 7.2.4, FortiNDR 7.0.0 through 7.0.6, FortiRecorder 7.2.0 through 7.2.3, FortiRecorder 7.0.0 through 7.0.5, FortiRecorder 6.4.0 through 6.4.5, FortiVoice 7.2.0, FortiVoice 7.0.0 through 7.0.6, FortiVoice 6.4.0 through 6.4.10 allows a remote unauthenticated attacker to execute arbitrary code or commands via sending HTTP requests with specially crafted hash cookie.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Fortinet FortiNDR

    From 7.4.0 · through 7.4.7; From 7.2.0 · through 7.2.4; From 7.1.0 · through 7.1.1; From 7.0.0 · through 7.0.6; From 1.5.0 · through 1.5.3; From 1.3.0 · through 1.3.1

  • Fortinet FortiCamera

    From 2.1.0 · through 2.1.3; From 1.1.0 · through 1.1.5

  • Fortinet FortiRecorder

    From 7.2.0 · through 7.2.3; From 7.0.0 · through 7.0.5; From 6.4.0 · through 6.4.5

  • Fortinet FortiVoice

    From 7.0.0 · through 7.0.6; From 6.4.0 · through 6.4.10

  • Fortinet FortiMail

    From 7.6.0 · through 7.6.2; From 7.4.0 · through 7.4.4; From 7.2.0 · through 7.2.7; From 7.0.0 · through 7.0.8

References 1

fortiguard.fortinet.com

FAQ

Questions about CVE-2025-32756

What does this mean?

This is a stack-based buffer overflow (CWE-121) that crafted HTTP requests sent to the portal or administrative interface can trigger. The advisory says an attacker could execute arbitrary code or commands on the device.Source: fortiguard.fortinet.com

Am I affected, and how do I check?

The listed affected ranges are FortiCamera 2.1.0 through 2.1.3 and 1.1.0 through 1.1.5. Compare the version shown on your device with these ranges, and note that the issue requires the portal or administrative HTTP/HTTPS interface.Source: fortiguard.fortinet.com

What should I do about it?

Upgrade to FortiCamera 2.1.4 or above, which the advisory gives as the fix.Source: fortiguard.fortinet.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-05-14, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data