Skip to main content
← All vulnerabilities
CVE-2025-32433

Erlang/OTP SSH Vulnerable to Pre-Authentication RCE

Affects the Erlang/OTP SSH server from OTP 17.0 onward, per the advisory. Fixed in OTP-27.3.3, OTP-26.2.5.11, and OTP-25.3.2.20.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in OTP-27.3.3, OTP-26.2.5.11, OTP-25.3.2.20
None on Exploit-DB, Metasploit or GitHub

Summary

Erlang/OTP, the libraries used to build Erlang applications, is affected when its built-in SSH server is running. An attacker who can reach that server could exploit a flaw in how it handles SSH messages to run arbitrary commands on the system without logging in.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Erlang/OTP is a set of libraries for the Erlang programming language. Prior to versions OTP-27.3.3, OTP-26.2.5.11, and OTP-25.3.2.20, a SSH server may allow an attacker to perform unauthenticated remote code execution (RCE). By exploiting a flaw in SSH protocol message handling, a malicious actor could gain unauthorized access to affected systems and execute arbitrary commands without valid credentials. This issue is patched in versions OTP-27.3.3, OTP-26.2.5.11, and OTP-25.3.2.20. A temporary workaround involves disabling the SSH server or to prevent access via firewall rules.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • erlang otp

    From OTP-27.0-rc1 · fixed in OTP-27.3.3; From OTP-26.0-rc1 · fixed in OTP-26.2.5.11; fixed in OTP-25.3.2.20

References 4

GitHub · erlang/otp

FAQ

Questions about CVE-2025-32433

What does this mean?

The flaw lets an unauthenticated remote attacker run arbitrary commands on the host without valid credentials. The advisory also says it may cause denial of service or allow manipulation of sensitive data.Source: github.com

Am I affected, and how do I check?

The advisory says all users running the Erlang/OTP SSH server are impacted, starting from OTP 17.0. To check a system, confirm whether the SSH server is running and which OTP release is installed.Source: github.com

What should I do about it?

Update to OTP-27.3.3 for OTP-27, OTP-26.2.5.11 for OTP-26, or OTP-25.3.2.20 for OTP-25. Until the upgrade, disable the SSH server or block access to it with firewall rules.Source: github.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-06-09, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data