Craft CMS Allows Remote Code Execution
Affects Craft CMS 3.0.0-RC1 to 3.9.14, 4.0.0-RC1 to 4.14.14, and 5.0.0-RC1 to 5.6.16. Fixed in 3.9.15, 4.14.15, and 5.6.17.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 3.9.15, 4.14.15, 5.6.17
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Craft CMS, a content management system used to build websites and digital experiences, is affected by this flaw. An attacker who can reach the site remotely could run arbitrary code on the server, which could give them control over the affected system.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an additional fix for CVE-2023-41892.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- Record last updated
- CISA remediation deadline
Due date for US federal agencies to patch
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- craftcms cms
From 3.0.0-RC1 · fixed in 3.9.15; From 4.0.0-RC1 · fixed in 4.14.15; From 5.0.0-RC1 · fixed in 5.6.17
- craftcms/cmsPackagist
From 3.0.0-RC1 · fixed in 3.9.15
- craftcms/cmsPackagist
From 4.0.0-RC1 · fixed in 4.14.15
- craftcms/cmsPackagist
From 5.0.0-RC1 · fixed in 5.6.17
References 5
Questions about CVE-2025-32432
What does this mean?
The flaw allows remote code execution on the affected Craft CMS installation. The impact is high on confidentiality, integrity, and availability.Source: github.com
Am I affected, and how do I check?
Craft CMS versions 3.0.0-RC1 through 3.9.14, 4.0.0-RC1 through 4.14.14, and 5.0.0-RC1 through 5.6.16 are affected. To check, compare the installed Craft CMS version against the range for its major version line.Source: github.com
What should I do about it?
Upgrade to 3.9.15, 4.14.15, or 5.6.17, whichever matches the installed major version line.Source: github.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-03-20, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data