Skip to main content
← All vulnerabilities
CVE-2025-25257

An improper neutralization of special elements used in an SQL command ('SQL Injection') vulnerability [CWE-89] vulnerability in Fortinet For

Affects FortiWeb 7.0.0 through 7.6.3 in the listed version ranges; FortiWeb 6.4 is not affected. Fixed in 7.6.4.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 7.6.4
None on Exploit-DB, Metasploit or GitHub

Summary

Fortinet FortiWeb, a web application firewall, is affected by this SQL injection flaw. An unauthenticated attacker could send specially crafted HTTP or HTTPS requests to run unauthorized SQL commands, potentially accessing or altering data.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

An improper neutralization of special elements used in an SQL command ('SQL Injection') vulnerability [CWE-89] vulnerability in Fortinet FortiWeb 7.6.0 through 7.6.3, FortiWeb 7.4.0 through 7.4.7, FortiWeb 7.2.0 through 7.2.10, FortiWeb 7.0.0 through 7.0.10 allows an unauthenticated attacker to execute unauthorized SQL code or commands via crafted HTTP or HTTPs requests.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Fortinet FortiWeb

    From 7.6.0 · through 7.6.3; From 7.4.0 · through 7.4.7; From 7.2.0 · through 7.2.10; From 7.0.0 · through 7.0.10

References 1

fortiguard.fortinet.com

FAQ

Questions about CVE-2025-25257

What does this mean?

This is an SQL injection flaw, where crafted input is handled as SQL commands. It may allow an unauthenticated attacker to execute unauthorized SQL code or commands on the FortiWeb device.Source: fortiguard.fortinet.com

Am I affected, and how do I check?

Affected FortiWeb versions are 7.6.0 through 7.6.3, 7.4.0 through 7.4.7, 7.2.0 through 7.2.10, and 7.0.0 through 7.0.10. FortiWeb 6.4 is not affected. To check, compare the installed FortiWeb version against these ranges.Source: fortiguard.fortinet.com

What should I do about it?

Upgrade to FortiWeb 7.6.4 or above, as stated in the vendor's fix guidance.Source: fortiguard.fortinet.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-07-18, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data