Skip to main content
← All vulnerabilities
CVE-2025-25249

A heap-based buffer overflow vulnerability in Fortinet FortiOS 7.6.0 through 7.6.3, FortiOS 7.4.0 through 7.4.8, FortiOS 7.2.0 through 7.2.1

Affects FortiOS 7.6.0 through 7.6.3, 7.4.0 through 7.4.8, and 7.2.0 through 7.2.11, plus FortiSwitchManager 7.2.0 through 7.2.6. The listed upgrade target is 7.6.4.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 7.6.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: active
  • Automatable: no
  • Technical impact: total

Summary

A heap-based buffer overflow in Fortinet's FortiOS network operating system and its FortiSwitchManager companion product lets an attacker run unauthorized code or commands on affected devices by sending specially crafted network packets. Successful exploitation could give the attacker control over the device, compromising its confidentiality, integrity, and availability.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

A heap-based buffer overflow vulnerability in Fortinet FortiOS 7.6.0 through 7.6.3, FortiOS 7.4.0 through 7.4.8, FortiOS 7.2.0 through 7.2.11, FortiOS 7.0.0 through 7.0.17, FortiOS 6.4 all versions, FortiSwitchManager 7.2.0 through 7.2.6, FortiSwitchManager 7.0.0 through 7.0.5 allows attacker to execute unauthorized code or commands via specially crafted packets

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA SSVC assessment

    Exploitation: active · Automatable: no · Technical impact: total

  4. CISA remediation deadline

    Due date for US federal agencies to patch

  5. Record last updated

Affected versions

  • Fortinet FortiSwitchManager

    From 7.2.2 · through 7.2.5

  • Fortinet FortiOS

    From 7.6.0 · through 7.6.2; From 7.4.0 · through 7.4.7; From 7.2.4 · through 7.2.11

References 1

fortiguard.fortinet.com

FAQ

Questions about CVE-2025-25249

What does this mean?

A heap-based buffer overflow in FortiOS can be triggered by specifically crafted requests, allowing arbitrary code or commands to be executed on the affected device.Source: fortiguard.fortinet.com

Am I affected, and how do I check?

FortiOS 7.6.0 through 7.6.3, 7.4.0 through 7.4.8, 7.2.0 through 7.2.11, 7.0.0 through 7.0.17, and 6.4 (all versions); FortiSwitchManager 7.2.0 through 7.2.6 and 7.0.0 through 7.0.5. Compare the installed version against these ranges.Source: fortiguard.fortinet.com

What should I do about it?

Upgrade to FortiOS 7.6.4 or above, as the advisory states.Source: fortiguard.fortinet.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-09-09, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data