Skip to main content
← All vulnerabilities
CVE-2025-24472

An Authentication Bypass Using an Alternate Path or Channel vulnerability [CWE-288] affecting FortiOS 7.0.0 through 7.0.16 and FortiProxy 7.

Affects FortiOS 7.0.0 through 7.0.16 and FortiProxy 7.0 and 7.2 versions, where Security Fabric (CSF) is enabled. Fixed in FortiOS 7.0.17.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 7.0.17
None on Exploit-DB, Metasploit or GitHub

Summary

This vulnerability affects Fortinet's FortiOS and FortiProxy operating systems used in FortiGate and FortiProxy security appliances, when the Security Fabric feature is enabled. A remote attacker who knows the serial numbers of the connected upstream and downstream devices could bypass authentication and gain super-admin control of the downstream device.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

An Authentication Bypass Using an Alternate Path or Channel vulnerability [CWE-288] affecting FortiOS 7.0.0 through 7.0.16 and FortiProxy 7.2.0 through 7.2.12, 7.0.0 through 7.0.19 may allow a remote unauthenticated attacker with prior knowledge of upstream and downstream devices serial numbers to gain super-admin privileges on the downstream device, if the Security Fabric is enabled, via crafted CSF proxy requests.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated

Affected versions

  • Fortinet FortiOS

    From 7.0.0 · through 7.0.16

  • Fortinet FortiProxy

    From 7.2.0 · through 7.2.12; From 7.0.0 · through 7.0.19

References 1

fortiguard.fortinet.com

FAQ

Questions about CVE-2025-24472

What does this mean?

A flaw in authentication lets a remote attacker gain super-admin privileges on the device using crafted requests to the Node.js websocket module or crafted CSF proxy requests.Source: fortiguard.fortinet.com

Am I affected, and how do I check?

FortiOS 7.0.0 through 7.0.16 and FortiProxy 7.0.0 through 7.0.19 and 7.2.0 through 7.2.12 are listed as affected, and the exposure applies when Security Fabric (CSF) is enabled on the device. To check, compare the installed firmware version against these ranges and review whether Security Fabric is enabled in the device settings.Source: fortiguard.fortinet.com

What should I do about it?

Upgrade FortiOS to 7.0.17 or above, which the vendor lists as the fix.Source: fortiguard.fortinet.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-03-18, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data