Skip to main content
← All vulnerabilities
CVE-2025-22224

VMware ESXi, and Workstation contain a TOCTOU (Time-of-Check Time-of-Use) vulnerability that leads to an out-of-bounds write.

Affects VMware ESXi 7.0 and 8.0 and VMware Workstation 17.x, with exposure requiring local administrative privileges on a virtual machine. Fixed in ESXi 8.0U3d, 8.0U2d, 7.0U3s and Workstation 17.6.3.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in ESXi80U3d-24585383, ESXi80U2d-24585300, ESXi70U3s-24585291, 17.6.3
None on Exploit-DB, Metasploit or GitHub

Summary

VMware ESXi and VMware Workstation are affected by this vulnerability. A malicious user with local administrator access inside a virtual machine could exploit it to run code as the VMX process on the host system.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

VMware ESXi, and Workstation contain a TOCTOU (Time-of-Check Time-of-Use) vulnerability that leads to an out-of-bounds write. A malicious actor with local administrative privileges on a virtual machine may exploit this issue to execute code as the virtual machine's VMX process running on the host.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated

Affected versions

  • VMware ESXi

    From 8.0 · fixed in ESXi80U3d-24585383; From 8.0 · fixed in ESXi80U2d-24585300; From 7.0 · fixed in ESXi70U3s-24585291

  • VMware Workstation

    From 17.x · fixed in 17.6.3

  • VMware VMware Cloud Foundation

    5.x, 4.5.x

  • VMware Telco Cloud Platform

    5.x, 4.x, 3.x, 2.x

  • VMware Telco Cloud Infrastructure

    3.x, 2.x

References 1

support.broadcom.com

FAQ

Questions about CVE-2025-22224

What does this mean?

A time-of-check time-of-use flaw can lead to an out-of-bounds write. Per the advisory, a local administrator on a virtual machine may use it to execute code as that VM's VMX process on the host.Source: support.broadcom.com

Am I affected, and how do I check?

The advisory lists VMware ESXi 7.0 and 8.0 and VMware Workstation 17.x. To check an ESXi host, compare its version and build shown in the host summary or by running vmware -v in the ESXi shell; for Workstation, check the version under Help > About.Source: support.broadcom.com

What should I do about it?

Upgrade ESXi to ESXi80U3d-24585383 for 8.0 U3, ESXi80U2d-24585300 for 8.0 U2, or ESXi70U3s-24585291 for 7.0 U3, and upgrade Workstation to 17.6.3 or later.Source: support.broadcom.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-03-04, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data