Skip to main content
← All vulnerabilities
CVE-2025-21927

nvme-tcp: fix potential memory corruption in nvme_tcp_recv_pdu()

Affects the Linux kernel nvme-tcp driver from 5.0.0 when header digests are enabled. Fixed in kernel releases 6.6.160, 6.12.19 and 6.13.7.

Published
Last modified
published
Not listed in CISA KEV
Unclear
Fix
Fixed in 6.6.160, 6.12.19, 6.13.7
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

The Linux kernel's NVMe over TCP driver (nvme-tcp) is affected. A malicious or faulty storage target sending a packet with an invalid header length can cause the kernel to write past the end of an allocated buffer, corrupting kernel memory, which could crash the system or lead to other unintended behavior.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

In the Linux kernel, the following vulnerability has been resolved: nvme-tcp: fix potential memory corruption in nvme_tcp_recv_pdu() nvme_tcp_recv_pdu() doesn't check the validity of the header length. When header digests are enabled, a target might send a packet with an invalid header length (e.g. 255), causing nvme_tcp_verify_hdgst() to access memory outside the allocated area and cause memory corruptions by overwriting it with the calculated digest. Fix this by rejecting packets with an unexpected header length.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Linux Linux

    Version range not reported

  • Linux Linux

    5.0

  • KernelLinux

    From 5.0.0 · fixed in 6.6.160; From 6.7.0 · fixed in 6.12.19; From 6.13.0 · fixed in 6.13.7

References 5

git.kernel.org

FAQ

Questions about CVE-2025-21927

What does this mean?

When header digests are enabled, a target might send a packet with an invalid length. The kernel can then access memory outside the allocated area and overwrite it with the calculated digest, causing memory corruption.Source: git.kernel.org

Am I affected, and how do I check?

The affected range is the Linux kernel nvme-tcp code from 5.0.0 up to the fixed releases 6.6.160, 6.12.19 and 6.13.7, with the 6.7 branch covered by 6.12.19. The relevant setup is NVMe over TCP with header digests enabled; check the running kernel with uname -r and whether NVMe over TCP is in use with header digests on.Source: git.kernel.org

What should I do about it?

Upgrade to kernel 6.6.160, 6.12.19, 6.13.7 or a later release in the matching branch.Source: git.kernel.org

Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data