Code injection exposure in Fabric OS 9.1.0 through 9.1.1d6
Affects Brocade Fabric OS versions 9.1.0 through 9.1.1d6, where a local user with an admin role can run arbitrary code with root privileges. Fixed in 9.1.1d7.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 9.1.1d7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Brocade Fabric OS, the operating system used in Brocade storage area network switches, is affected by this vulnerability. A local user with administrator privileges could run arbitrary code with full root access, despite root access having been removed in these releases.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Brocade Fabric OS versions starting with 9.1.0 have root access removed, however, a local user with admin privilege can potentially execute arbitrary code with full root privileges on Fabric OS versions 9.1.0 through 9.1.1d6.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
Affected versions
- Brocade Fabric OS
Fabric OS versions 9.1.0 through 9.1.1d6
References 1
Questions about CVE-2025-1976
What does this mean?
A local user with an admin role can execute arbitrary code with full root-level access. From there they can run any Fabric OS command or modify Fabric OS itself, including adding their own subroutines.Source: support.broadcom.com
Am I affected, and how do I check?
Fabric OS versions 9.1.0 through 9.1.1d6 are affected. The issue requires the user to hold a pre-defined admin role or a user-defined role with admin-level privileges. To check, look at the installed Fabric OS version on the device and the roles assigned to its users.Source: support.broadcom.com
What should I do about it?
Upgrade to Brocade Fabric OS 9.1.1d7, which provides the security update.Source: support.broadcom.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-04-28, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data