Improper IDP Status Validation via JWT Bearer or SAML2 Bearer Grants in Multiple WSO2 Products Allows Access Token Issuance for Disabled…
Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.
- Exploited
- No known exploitation
- Fix
- Fixed in 4.5.0.10, 3.1.0.321, 3.2.0.414, 3.2.1.50, 4.0.0.335, and 33 more
- Who is exposed
- Not reported
Do first: Upgrade to a fixed version: 4.5.0.10, 3.1.0.321, 3.2.0.414, 3.2.1.50, 4.0.0.335, or one of 33 more.
- Exploitation0/40No signal
- Exposure17/25No login or user action needed per the CVSS vector, reachable over the network without a login · Data gap: No advisory context yet
- Reach?/20Reach: unknown (data gap). No tracked technology or package matched
- Severity4.8/10CVSS 4.8
- No patch0/5No signal
What would change the score
- Would score about 67 if added to CISA KEV
- Would score about 62 if CISA's SSVC rates exploitation active
- Would score about 27 if advisories confirm default setups are exposed
CVE-2025-1397 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 4.8 (medium) and affects WSO2 Universal Gateway, WSO2 Traffic Manager, WSO2 API Manager and 7 more; fixed in 4.5.0.10, 3.1.0.321, 3.2.0.414 and 35 more.
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- Published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- FIRST's estimate of the chance attackers exploit it in the next 30 days, updated daily.What do these mean? →
- 0.15% · 4th percentile
- A 0-100 score for how much a CVE matters across the industry: exploitation, exposure, how widely the software is used, severity and whether a fix exists.What do these mean? →
- 22/100 · provisional
- Fix
- Fixed in 4.5.0.10, 3.1.0.321, 3.2.0.414, 3.2.1.50, 4.0.0.335, and 33 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
This vulnerability affects multiple WSO2 products that use the JWT Bearer or SAML2 Bearer grant types to issue access tokens. An attacker could exploit the flaw to obtain access tokens through a disabled Identity Provider, potentially gaining access to protected resources that should be blocked.
Read the original description
When utilizing JWT Bearer or SAML2 Bearer grant types, the system fails to validate the status of the Identity Provider (IDP) before issuing access tokens. This oversight permits tokens to be generated even when the associated IDP has been disabled. A malicious actor could leverage this vulnerability to obtain access tokens by targeting a disabled IDP. This could enable them to bypass intended security controls and potentially access protected resources that should be inaccessible due to the IDP's disabled state.
What to do
Upgrade to a fixed version: 4.5.0.10, 3.1.0.321, 3.2.0.414, 3.2.1.50, 4.0.0.335, or one of 33 more.
Timeline
- CVE published
- First seen by cve.now
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- WSO2 WSO2 Universal Gateway
From 4.5.0 · fixed in 4.5.0.10
- WSO2 WSO2 Traffic Manager
From 4.5.0 · fixed in 4.5.0.10
- WSO2 WSO2 API Manager
From 3.1.0 · fixed in 3.1.0.321; From 3.2.0 · fixed in 3.2.0.414; From 3.2.1 · fixed in 3.2.1.50; From 4.0.0 · fixed in 4.0.0.335; From 4.1.0 · fixed in 4.1.0.211; From 4.2.0 · fixed in 4.2.0.150; From 4.3.0 · fixed in 4.3.0.63; From 4.4.0 · fixed in 4.4.0.26; From 4.5.0 · fixed in 4.5.0.10
- WSO2 WSO2 API Control Plane
From 4.5.0 · fixed in 4.5.0.11
- WSO2 WSO2 Identity Server
From 5.10.0 · fixed in 5.10.0.346; From 5.11.0 · fixed in 5.11.0.396; From 6.0.0 · fixed in 6.0.0.232; From 6.1.0 · fixed in 6.1.0.224; From 7.0.0 · fixed in 7.0.0.93
- WSO2 WSO2 Open Banking AM
From 2.0.0 · fixed in 2.0.0.370
- WSO2 WSO2 Open Banking IAM
From 2.0.0 · fixed in 2.0.0.390
- WSO2 WSO2 Identity Server as Key Manager
From 5.10.0 · fixed in 5.10.0.339
Show all 10 packagesShow fewer packages
- org.wso2.carbon.identity.inbound.auth.oauth2:org.wso2.carbon.identity.oauth
From 6.4.2 · fixed in 6.4.2.155; From 6.4.111 · fixed in 6.4.111.134; From 6.4.176 · fixed in 6.4.176.25; From 6.4.180 · fixed in 6.4.180.11; From 6.8.0 · fixed in 6.8.0.49; From 6.9.6 · fixed in 6.9.6.22; From 6.11.21 · fixed in 6.11.21.75; From 6.13.16 · fixed in 6.13.16.15; From 6.13.19 · fixed in 6.13.19.9; From 6.13.27 · fixed in 6.13.27.2; From 7.0.26 · fixed in 7.0.26.58
- org.wso2.carbon.extension.identity.oauth2.grantType.jwt:org.wso2.carbon.identity.oauth2.grant.jwt
From 1.0.26 · fixed in 1.0.26.6; From 1.0.26 · fixed in 1.0.26.7; From 1.0.31 · fixed in 1.0.31.3; From 1.1.0 · fixed in 1.1.0.2; From 2.0.4 · fixed in 2.0.4.3; From 2.1.1 · fixed in 2.1.1.2; From 2.2.0 · fixed in 2.2.0.3; From 2.2.4 · fixed in 2.2.4.1; From 2.3.1 · fixed in 2.3.1.4
Evidence 1
- Advisory
Corrections
None so far.
Something wrong on this page? Report an error. Every fix is listed here.
Questions about CVE-2025-1397
Is CVE-2025-1397 being exploited?
It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data
Which versions are affected by CVE-2025-1397?
WSO2 Universal Gateway: from 4.5.0 before 4.5.0.10. WSO2 Traffic Manager: from 4.5.0 before 4.5.0.10. WSO2 API Manager: from 3.1.0 before 3.1.0.321; from 3.2.0 before 3.2.0.414; from 3.2.1 before 3.2.1.50; from 4.0.0 before 4.0.0.335; from 4.1.0 before 4.1.0.211; from 4.2.0 before 4.2.0.150; from 4.3.0 before 4.3.0.63; from 4.4.0 before 4.4.0.26; from 4.5.0 before 4.5.0.10. WSO2 API Control Plane: from 4.5.0 before 4.5.0.11. WSO2 Identity Server: from 5.10.0 before 5.10.0.346; from 5.11.0 before 5.11.0.396; from 6.0.0 before 6.0.0.232; from 6.1.0 before 6.1.0.224; from 7.0.0 before 7.0.0.93. 5 more packages are listed on the page.Source: cve.now feed data
How do I fix CVE-2025-1397?
Upgrade to a fixed version: 4.5.0.10, 3.1.0.321, 3.2.0.414, 3.2.1.50, 4.0.0.335, or one of 33 more.Source: cve.now feed data