Skip to main content
← Vulnerabilities

Privilege Escalation via Client Credentials Grant Type in WSO2 Identity Server

Only WSO2 Identity Server 7.0.0 and 7.1.0 deployments with authorize_all_scopes enabled in deployment.toml are affected. Fixed in 7.0.0.125 and 7.1.0.32.

Written by anthropic/claude-haiku-5.5 from the sources below. Verify against them.

7.2HighCNA
Exploited
No known exploitation
Fix
Fixed in 7.0.0.125, 7.1.0.32, 7.0.78.137, 7.8.23.49
Who is exposed
Specific setups only

Do first: Check whether your setup matches what the bug needs. WSO2 Identity Server 7.1.0 or 7.0.0 with the authorize_all_scopes configuration enabled in deployment.toml Affected products are WSO2 Identity Server 7.1.0 and 7.0.0

15Pcve.now Index 15 of 100 · methodology v3 · provisional
  • Exploitation?/40Exploitation: unknown (data gap). No CISA SSVC exploitation rating yet
  • Exposure8/25Specific setups only, reachable over the network
  • Reach?/20Reach: unknown (data gap). No tracked technology or package matched
  • Severity7.2/10CVSS 7.2
  • No patch0/5No signal

What would change the score

  • Would score about 65 if added to CISA KEV
  • Would score about 60 if CISA's SSVC rates exploitation active
  • Would score about 22 if CISA's SSVC rates it automatable

CVE-2025-11229 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.2 (high) and affects WSO2 Identity Server and WSO2 Identity Application Management Component; fixed in 7.0.0.125, 7.1.0.32, 7.0.78.137 and 1 more.

Published
Last modified
Published
Not listed in CISA KEV
0.36% · 29th percentile
15/100 · provisional
Specific setups only
Fix
Fixed in 7.0.0.125, 7.1.0.32, 7.0.78.137, 7.8.23.49
None on Exploit-DB, Metasploit or GitHub

Summary

WSO2 Identity Server fails to enforce scope authorization when the `authorize_all_scopes` setting is enabled, letting applications that use the client credentials grant obtain all API scopes, including sensitive internal and console scopes, without explicit approval. An attacker who can reach the server over the network and log in with high-level privileges could escalate privileges to perform unauthorized administrative actions and access confidential organizational data.

Read the original description

The system fails to properly enforce scope authorization when the `authorize_all_scopes` configuration is enabled. This allows applications using the client credentials grant type to obtain all API scopes, including sensitive internal and console scopes, without requiring explicit authorization, bypassing intended access controls. Exploitation of this vulnerability can lead to privilege escalation, enabling unprivileged clients to perform unauthorized administrative actions, access confidential organizational data, and potentially achieve full account takeover in deployments where the `authorize_all_scopes` configuration deviates from its default disabled state.

What to do

  • Check whether your setup matches what the bug needs.

    WSO2 Identity Server 7.1.0 or 7.0.0 with the authorize_all_scopes configuration enabled in deployment.toml Affected products are WSO2 Identity Server 7.1.0 and 7.0.0
  • Upgrade to a fixed version: 7.0.0.125, 7.1.0.32, 7.0.78.137, 7.8.23.49.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • WSO2 WSO2 Identity Server

    From 7.0.0 · fixed in 7.0.0.125; From 7.1.0 · fixed in 7.1.0.32

  • org.wso2.carbon.identity.framework:org.wso2.carbon.identity.application.mgt

    From 7.0.78 · fixed in 7.0.78.137; From 7.8.23 · fixed in 7.8.23.49

Evidence 1

  1. Advisory

Corrections

None so far.

Something wrong on this page? Report an error. Every fix is listed here.

FAQ

Questions about CVE-2025-11229

Is CVE-2025-11229 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.Source: cve.now feed data

What does this mean?

An application that uses the client credentials grant type can obtain all API scopes, including sensitive internal and console scopes. That access can lead to privilege escalation, unauthorized administrative actions, and exposure of sensitive organizational data.Source: security.docs.wso2.com

Which versions are affected by CVE-2025-11229?

WSO2 Identity Server: from 7.0.0 before 7.0.0.125; from 7.1.0 before 7.1.0.32. org.wso2.carbon.identity.framework:org.wso2.carbon.identity.application.mgt: from 7.0.78 before 7.0.78.137; from 7.8.23 before 7.8.23.49.Source: cve.now feed data

Am I affected, and how do I check?

WSO2 Identity Server 7.0.0 before 7.0.0.125 and 7.1.0 before 7.1.0.32 are affected, but only where the authorize_all_scopes configuration is enabled in deployment.toml. The advisory also lists WSO2 Identity Application Management Component 7.0.78 before 7.0.78.137 and 7.8.23 before 7.8.23.49. To check the setting, look for authorize_all_scopes in deployment.toml, and compare the product version with the ranges above.Source: security.docs.wso2.com

How do I fix CVE-2025-11229?

Upgrade WSO2 Identity Server to 7.0.0.125 or 7.1.0.32, or to the matching fixed release for the Application Management Component.Source: security.docs.wso2.com