Skip to main content
← All vulnerabilities
CVE-2024-8069

Limited remote code execution with privilege of a NetworkService Account access

Affects Citrix Session Recording 1912 LTSR, 2203 LTSR, 2402 LTSR and 2407 Current Release builds before their listed hotfixes. Fixed in 2407 hotfix 24.5.200.8 and later.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 24.5.200.8, CU9 hotfix 19.12.9100.6, CU5 hotfix 22.03.5100.11, CU1 hotfix 24.02.1200.16
None on Exploit-DB, Metasploit or GitHub

Summary

Citrix Session Recording, a component used to record user sessions, is affected by this vulnerability. An authenticated attacker on the same internal network as the session recording server could run limited code remotely with the privileges of a NetworkService account.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Limited remote code execution with privilege of a NetworkService Account access in Citrix Session Recording if the attacker is an authenticated user on the same intranet as the session recording server

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Citrix Session Recording Citrix Session Recording

    From 2407 Current Release · fixed in 24.5.200.8; From 1912 LTSR · fixed in CU9 hotfix 19.12.9100.6; From 2203 LTSR · fixed in CU5 hotfix 22.03.5100.11; From 2402 LTSR · fixed in CU1 hotfix 24.02.1200.16

References 1

support.citrix.com

FAQ

Questions about CVE-2024-8069

What does this mean?

The bug allows limited remote code execution, meaning code sent from another system could run on the server with the limited privileges of the NetworkService account.Source: support.citrix.com

Am I affected, and how do I check?

Citrix Session Recording 2407 Current Release before hotfix 24.5.200.8, 1912 LTSR before CU9 hotfix 19.12.9100.6, 2203 LTSR before CU5 hotfix 22.03.5100.11, and 2402 LTSR before CU1 hotfix 24.02.1200.16. A reader can check by comparing the installed Session Recording version and hotfix level against these listed builds.Source: support.citrix.com

What should I do about it?

Move to 2407 hotfix 24.5.200.8 or later for the Current Release. For LTSR branches, install the matching fixed build: CU9 hotfix 19.12.9100.6, CU5 hotfix 22.03.5100.11, or CU1 hotfix 24.02.1200.16.Source: support.citrix.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-08-25, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data